3.11 Duet Web Controll disconnected and unresposive



  • Hello, I just upgraded firmware to latest 3.11 and every browser returns disconnected, inresponsive UI.

    YAT says:
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.1.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-05-19b2

    WiFi module is connected to access point and have IP address

    Installation process:
    I copied files from Duet2and3Firmware-3.1.1.zip to sys on SD card from my computer.
    Reinserted SD card to board.
    Connect with YAT.
    Connect to wifi M552 S1
    Run M997 S0
    Reset
    Run M997 S1
    Reset

    Really strange thing is that twice it randomly was get conncted

    Any suggestions?

    Thanx



  • Now, after countless reload .

    1. Button in the left top corner changed color to green, but next to red buttonon the left si Gray rectangle with text Disconnected.
    2. Menu items are clickable, but Configuration file tab says loading.
    3. In the middle next to My Duet is yellow rectangle with "some axes are not homed"

    After next page reload same unresponsive UI
    😕


  • Moderator

    Can you try replacing the contents of the /www folder on the SD card with the contents of this zip file?

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.1.1/DuetWebControl-SD-3.1.1.zip


  • Moderator

    Also, clear your browser cache.



  • Thanx for answer! 🙂
    I am definitely doing something wrong.
    Now page says
    "Your Duet rejected the HTTP request: page not found"
    😕

    I unzipped file to www folder on the card - and the browser says that
    Tried to type M997 S1 - same answer from browser
    I unzipped all the .gz files - same
    tha again M997 S1 - same

    before this i tried to return to other versions of firmware and always did M997 S1 and M997 S0.

    never got connected to board
    im startin to think that board is bad 😞



  • Hello 🙂
    Again thanx for your help!

    I am not sure what I did differently but after uploading 2.05 firmware and dwc board start working. Now works every other FW too.

    Strange, but I am happy 😄


  • Moderator

    Might have been missing an IAP file from one of the previous versions. There is a complete zip file with the main releases that contains everything needed. Usually best to go with that rather than the singular bin files.


Log in to reply