Duet3 3beta12 Error: "Duet3iap_sd_MB6HC.bin" not found



  • Dear all,

    Recently bought the Duet3 and now all up and running. It came with 3beta 12 though and I get errors while uploading gcode from CURA:

    Error: Uploaded file CRC is different (9bbf6177 vs. expected d95a03a3)

    I think it is related to this thread:

    https://forum.duet3d.com/topic/14445/help-uploaded-crc-is-different-25e2595f-vs-expected-2080b701

    and basically I need to open GCode files to delete lines with too many characters (too) which got solved in version 3.1:

    https://github.com/Duet3D/RepRapFirmware/blob/v3-dev/WHATS_NEW_RRF3.md

    Maximum GCode line length is increased from 160 to 200 characters

    So I've been trying to install the 3.1 but no success so far and I have found two threads on the topic here but I guess for experts as I can understand what they did exactly. So my request if someone can explain for dummies how it's done, where the files are exactly and the exact procedure?

    Here's my trial so far:

    I have following running at the moment:

    Duet Web Control 2.0.4
    Board: Duet 3 MB6HC
    Firmware: RepRapFirmware for Duet 3 MB6HC v0.6 or 1.0 3.0beta12 (2019-11-02b1)

    I downloaded from:

    https://github.com/Duet3D/RepRapFirmware/releases

    the file: Duet2and3Firmware-3.1.1.zip
    and extracted it on my mac. It contains many files but I thought I need the Duet3Firmware_MB6HC.bin file only so Uploaded that one. No auto FW update request made, so I tried to install with the M997 S0 command. It says:

    Error: In-application programming binary "Duet3iap_sd_MB6HC.bin" not found

    Well that file name was not in the zip file, but something similar: Duet3_SDiap_MB6HC.bin

    So renamed the file with similar name and uploaded the Duet3iap file as well.

    Now the M997 S0 does initiate something and a reboot but a few moments later the FW did not change.

    I then found one can also just upload the whole zip file so uploaded the complete zip downloaded above with the upload firmware button on the DWC.

    After upload the connection got lost and about 10 minutes later the DWC was back up and running, now on the new version "Duet Web Control 3.1.1" though. But the firmware is still at 3beta12.

    Unfortunately the DWC is now unstable and the the web interface connection is lost all the time. After another 10 minutes I therefore decided to power down the board and switch it on again.

    No success, so now I'm really stuck.

    My request: who can tell me what's best to do in my situation now and for others what they should do different then me to circumvent getting in my situation?

    Thank you!



  • hmm, I can add some more. I restarted my (Safari) browser and that helped with the connection issue. So I'm back where a started with the FW update in the sense that the bin file names etc is still the problem but now I have moved to the newest DWC already. ;-).

    I then deleted all the bin files the ZIP added to the sys directory and retried the procedure. Now I uploaded both iap (renamed) and the duet3 bin file and send another M997 S0. It asked me now to update automatically and indeed mentions to install the FW. But then it mentions an error: Operation has been cancelled

    Well I hope someone can help me point at the exact right files and procedure to get out of the 3beta12 situation!

    Thank you so much already!


  • administrators

    That file should have been included on the SD card. I have added a copy to https://github.com/Duet3D/RepRapFirmware/releases/tag/3.0 so you can download it from there. You won't need it any more once you are running firmware 3.0 or later.



  • Dear @dc42 ,

    Thank you very much for your super fast reply even on a Saturday morning. Highly appreciated.

    I downloaded the file you added and placed it (by DWC upload) on the SD card. I then found the name had "spi" instead of "SD" in it, so in order to execute the FW update I renamed the spi into SD.

    The firmware update started and it mentioned with the waiting bar it is doing just that. After 5 min I refreshed the browser, after another 5 min I switched off and on the power.

    My guess is it got stuck somewhere in the process and LAN connection is down now. So I guess were not there yet ;-).

    May I ask your advice once more? Can I get the SD out and put new files on it or should I go a different route with the hardware reset and all?

    Thank you and kind regards


  • administrators

    I'm sorry, you need the sd version of the file, not the spi one. I've now added that file to the release too. If your board is still running RepRapFirmware, you can download that file and try again. If it isn't then you will need to update the firmware via USB using Bossa.



  • Ok, that's rather unfortunate.

    I tried to connect with USB cable. On my Mac it does list the port (/dev/tty.usbmodem1442101) in my case but when I try and connect I get the message "Sorry could not find PTY". So I guess I'll need to go with Bossa and therefore have to ask around if I can borrow a PC from a friend or something (Indeed, I read in the procedure you need a PC or Linux and while trying to install on MAC it notes that the program is out of date to run on lates OS).

    With all the file trouble to start with and the Bossa procedure focussing on Duet2 rather than 3 I would value if you can point me to the exactly right files? Is it just the "Duet3Firmware_MB6HC.bin" this time and straight to the 3.1 version? And then just format the SD and put on the new sys directories etc?



  • @QuintBrand said in Duet3 3beta12 Error: "Duet3iap_sd_MB6HC.bin" not found:

    Is it just the "Duet3Firmware_MB6HC.bin" this time and straight to the 3.1 version?

    yes

    no need to format the card, just make sure to replace the IAP binary with the correct one for SD card instead of SPI. (but you can format and extract new files to /sys and /www to avoid updating DWC after bossa)

    Does bossa build if you run make bossac to only build the command line version and skip the gui?

    edit: maybe you could run ubuntu or some other linux distro in a virtual machine on the Mac and use USB passthough?



  • OK, success.

    Like Bearer suggested I tried connecting the Duet through my virtual machine (VMWare 11.1.1 (14328561) running Win10 (x64) pro (version 1903). Bossa was able to see the Duet when the USB connection is set to Windows on COM3.

    I then followed the #3 Fallback procedure on:

    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware

    where I have to say that the Diag LED was already lit when I started and the Jumper on Erase made no difference.

    After the Upload and Verify I disconnected the USB, Connected again and then could connect with the Apple Terminal again to the Duet.

    I deleted the .bin files I previously had uploaded in /sys and when connecting to the DWC I see I'm now running 3.1.1 (2020-05-19b2).

    Next up, check if I can now print the bigger Gcodes ;-).

    =======

    In summary for others to find how to get out of 3beta12: the files are now all added by @DC42 in the 3.1.1 release. Should anyone do a conformation that the normal Update procedure works would be nice!

    Big thanks to @DC42 for taking time even on a Saturday to help out. One very happy customer here.

    Cheers


  • administrators

    I'm glad you got it sorted. Upgrading the firmware should be much simpler from now on. You will need to have the Duet3_SDiap_MB6HC.bin file (as provided in the 3.0 or 3.1.1 release) present in /sys on the SD card for future upgrades. This is the IAP file used by RRF 3.0 stable and later when upgrading firmware.



  • Hi I have the same problem as you. And I also rename the Duet3_SDiap_MB6HC.bin fil, to Duet3iap_sd_MB6HC.bin.
    But as you still nu update.

    Then I read this post, and lock at the webpage https://github.com/Duet3D/RepRapFirmware/releases/tag/3.0, and there the file Duet3iap_sd_MB6HC.bin is 49K in size, but the fil we rename is only 32K.

    I download the Duet3iap_sd_MB6HC.bin from https://github.com/Duet3D/RepRapFirmware/releases/tag/3.0, and copy it ti the /sys folder, and then I udpdate without any problems from DWC. So no need to run the #3 Fallback procedure.



  • Hi @Finnls,

    Thank you for adding this information; nice to hear that with the right file in place one is able to update from 3beta12 to 3.1 without any additional operation.

    in the end it was actually also quite easy to use the Bossa software; I had expected more trouble doing so. So it was worth it in the end as I can now upload files from CURA without any errors now and I look forward experimenting with the new features.



  • @QuintBrand said in Duet3 3beta12 Error: "Duet3iap_sd_MB6HC.bin" not found:

    I think it is related to this thread:

    thanks for this exquisit thread, helped me fix this shit, too.


Log in to reply