UNSOLVED Duet 3 and laser

  • Hi,
    I am using duet 3 with Rpi 3 for my Workbee.
    In the moment I am planing to use it as laser engraver. I am using an endurance laser but somehow I can't connect it to the duet .
    The Laserbox of the endurance has two wires (black and red). In the endurance website, it shown only how to attache the endurance to the Duet WiFi. The two wire has to be attached to the connector fan 0.
    I tried to wire them in different way but I couldn't control the laser with M3 . I go only permeant laser with full power.
    Any ideas how should I wire the box and configure it ?
    thank you in advance.

  • Does anyone have an idea? 😊 it drives me crazy.
    my last try was:
    in the config.g file I declared the laser modus with: M452 C"out6" Q100
    the laser is attached to the 4k connector for fan (output 6). I wire only the pins: "v_outlc6" and "out6"
    But no chance. I can't adjust the output intensity of the laser. I am using M3 SXXX as a command.
    thank you.

  • You might have to invet the pin with !, as in M452 C"!out6" Q100

  • and use an IO port that support PWM; ref https://duet3d.dozuki.com/Wiki/Duet_3_Mainboard_6HC_Hardware_Overview#Section_IO

    out0..9 should support pwm all of them.

  • administrators

    Please provide a link to whatever information you have about the laser box.

  • the laser head is connected to the laser box with following schema:

    endurance laser suggests to connect the wire to the pin in fan0 but for the duet 2
    I can't find any information related to duet 3


  • @bearer
    unfortunately, doesn't help.
    do you know if the pins Voutlc_6 and out6 are the right pins to use? I am not very familiar with laser PWM signals .

  • Have you set the switch SW2 to II ?

    Not sure how the diagram would det the PWM input to open drain instead of push-pull but I guess you'll have to to try setting 0.

    The connection to the Duet3 will be the same, it has the same pins (just the addition of a ground and tachometer pin)

  • administrators

    As it says that the PWM input is open drain, my guess is that you need to connect the black wire of the PWM input connector to Duet ground, and the red wire to OUT- of your chosen OUT connector. But it's hard to be certain without a schematic of that board.

    You may find that the laser power setting works in reverse.

    PS - with the red and black wires not connected to the Duet, can you measure the voltage between them?

  • But if instructions say it works with the Duet2?

  • @meistron said in Duet 3 and laser:

    I tried to wire them in different way but I couldn't control the laser with M3 . I go only permeant laser with full power.

    According to Endurance Laser's website there's this snippet of how it works with a Duet board about half-way down the page.

    How to Connect to Duet3D Wifi Board

    The PWM input of the laser is connected to the Fan0 output of the Duet board.

    Power control teams
    M106 S127 – 50% power
    M106 S255 – 100% power
    M106 S0 – Laser Off

    On another page on the Endurance Website it has this section close to the top of the page


    Wiring to FAN0
    G-code command M106 P0 S1 /// min power
    G-code command M106 P0 S255 /// max power

    Learn more >>> https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans

    I don't think you can control the laser with M3, based on their website you have to use M106.

  • THANK YOU all for the inputs. I tried all possible possibilities but no one is working.
    the last what I tried:

    I connect the laser to the out 1 (heater 1) and declared it in the config: M452 C"!out1" Q200
    The light next to the output 1 is now red.
    If I send a command (M3 S100 or M106 S100) nothing happens.
    I inverted the wires and the laser got constant signal and was working in full power although the laser is in PWM mode.
    did I missed something in the the config files?

    the schematics and further information are to find under : https://endurancelasers.com/development-of-an-endurance-mo2-pcb/

  • administrators

    I suggest you connect the Laser/VFD output of the Duet to connector CN4 on that board. Then specify that you are using the laser/vfd pin in your M452 command.

    Use the S parameter on G1 commands to control the laser power.

  • Hmm..
    I attached the laser to the Laser pin and used M452 C"out9" Q100 but it doest work. I tried all possible combinations. Also !out9.

    I put the laser to in the out 9 (2pin for fan not the 2+3 for Laser)
    In laser mode the PWM doesn't control the laser. laser doesn't react on M3, G1, M106 .
    in FFF mode I can control the power of the laser with M106.

    For laser mode I was using: M452 C"!out9" Q100 to create the laser pin.
    Now I am using M950 F0 C"out9" Q100 T1 to create Fan 0 .. only after deactivating the M452 I can control the laser/fan with the M106. G1 Sxxx doest work in that case.

    Any hint what I am doing wrong.

  • administrators

    Just to be clear: if you connect the laser PWM input to the Laser/VFD output on the Duet, and configure a fan using M106 F0 C"out9", then you can control the laser using M106 P0 Sxx commands. Correct?

    If that is the case, then you should be able to use M452 C"out9" (provided the out9 pin is free when you do that), and then control the laser using the S parameter on G1 move commands. Note, the laser will only be on during G1 movement commands, for safety.

Log in to reply