M111 Debug shows : Network(1) and not Wifi Module?



  • Hey Everyone,

    Just started using a V1.02 DuetWifi for the first time. I have been using a V1.03 on another printer. I am trying to setup the board's wifi and M111 says --- Debugging enabled for modules: Network(1)

    M552 says --- Network is enabled, configured IP address: 192.168.1.14, actual IP address: 0.0.0.0

    When I setup the first board it said it was a wifi module. Is there something I am doing wrong? I checked the SD card that the board came with and it has 1.18 on it and I deleted the Ethernet and 0.85 firmware since I didn't want it to get confused between the options.

    Any help would be appreciated, this board has never been used before.

    -Ian



  • Not sure I understand the question?

    Maybe step 6 and 7 here will help? https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7#s9

    You don't need M111 to set up networking, only for unusual troubleshooting. Use M552, M578 as described in the link above.



  • I think I must be over thinking it. Since I haven't used this board before I should just start off by replacing the firmware with 2.05 and that might solve the issues



  • If you get an IP address like you showed then odds are network is all ok, but updating is probably a good idea, but it does have its challenges if updating form older versions of the firmware

    I think you're mixing board revisions and firmware versions maybe?

    in any case please refer to https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Special_considerations_for_upgrading_between_particular_firmware_versions for help with the upgarde.



  • I think I am confused because when I run M552, it doesn't give the status of the wifi module. I was thinking my DuetWifi was thinking it is a Duet with a network connection. I am just going to upgrade the firmware because it is pretty old at this point. I just don't think I can take the plunge into 3.0x yet....



  • @bearer Yeah that was the section of dozuki I am just about to follow, thanks for the help and I will post how it goes.



  • @UnderDoneSushi said in M111 Debug shows : Network(1) and not Wifi Module?:

    I think I am confused because when I run M552, it doesn't give the status of the wifi module. I was thinking my DuetWifi was thinking it is a Duet with a network connection. I am just going to upgrade the firmware because it is pretty old at this point. I just don't think I can take the plunge into 3.0x yet....

    ah, well, wifi is network module, its just not an ethernet network.

    to see the status specifically related to the wifi module look at M122 and almost at the bottom there will be some wifi status (you might have to configure your terminal line ending as the output is very long over several lines separated by line feed (LF)


Log in to reply