M563 Fan Mapping



  • Hello,
    I am having trouble using FAN2 as my part cooling fan. I had FAN0 as my part cooling fan, but i switched to magball arms and accidentally had both poles too close to the fan and it apparently burned out my FAN0 PWM channel because it no longer works. I swapped the arms so North and South are next to each other and now the fan works if I use FAN2, but only when i set it up as its own fan using M106. I want to set it up as my part cooling fan using M563 and mapping to the FAN2 output, but my DUET wifi does not seem to recognize this mapping. If I do this the fan never turns on. If I map it just using M106 it works just fine, but then i need to manually control when it is on/off rather than using my part cooling slicer settings. i have copy and pasted this section of my config.g file below. Can anyone please help me understand what I am doing wrong?

    Thank you in advance!

    ; Fans
    ;M106 P2 S1 I0 F500 H-1 ; FAN0 channel fried use FAN2 instead. set fan value, PWM signal inversion and frequency. Thermostatic control is turned off
    ;M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hot End" D0 H1 F2 ; define tool 0. FAN0 channel fried use FAN2 instead.
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C


  • administrators

    Have you selected tool 0 when you try to control the fan? The fan mapping only takes effect when the tool is selected.

    If you upgrade to RRF 3.1.1 you will be able to set up Fan0 use the Fan2 output.


Log in to reply