Duet 0.6 build firmware



  • Hi

    I have a two old duet 0.6 board which i intended to build a printer with. The project stalled but i really would like to extend the firmware. I tried building the firmware on debian but it seems as if
    RepRapFirmware-2.05.1, DuetNg-1.19 and RRFLibrary 435dc8f4f314c1376db2c9eb97005618a0b65cb1 don't really fit together?

    I really want to experiment and extend the FW and so downloading binaries is not what i want in the first place.

    Any idea what would be the best way to get the software compiled again?

    Also i would like to suggest to create a git repository with all the submodules where at least each release gets tagged versions as submodules. That makes it really easier to build the project.

    Best regards
    Tim

    PS: I just registered but there was an error in E-Mail confirmation page "Invalid Data There was a problem validating your email address. Perhaps the code was invalid or has expired.". But it seems i can post anyway.


  • Moderator

    I believe the latest release for the 0.6 boards is 1.26.1 which is current to 2.05.1.

    https://github.com/Duet3D/RepRapFirmware/releases/tag/2.05.1

    Are you talking about taking it beyond that?


  • administrators

    A few months ago I started tagging versions of the underlying projects that make a release, but that happened after the 2.05.1 release (1.26.1 for the Duet 0.6).

    I've just repeated the build of RRF for Duet 06/085 using the following branches, and it worked:

    RepRapFirmware dev
    CoreNG v2.05.2
    RRFLibraries master



  • Thanks @dc42
    RepRapFirmware dev
    CoreNG v2.05.2
    RRFLibraries master
    seemed to match much better 🙂
    I have a binary now.
    OpenOCD also seems to work with this board...


  • administrators

    @tstone said in Duet 0.6 build firmware:

    OpenOCD also seems to work with this board...

    Good to know. What JTAG or SWD interface hardware are you using?



  • @dc42 said in Duet 0.6 build firmware:

    What JTAG or SWD interface hardware are you using?

    I am using a ST-Link V2 with an Adafruit Cortex SMD adapter.
    Dev branch of openocd with the following config:

    source [find interface/stlink.cfg]
    set CPUTAPID 0x2ba01477
    source [find target/at91sam3XXX.cfg]

    It seems flashing is not working as expected...
    But flashing my built firmware with bossac worked. 🙂
    After that it seems i can can debug with this setup:
    Remote debugging using :3333
    0x000aa6b0 in FilamentMonitor::Spin() ()
    (gdb) bt
    #0 0x000aa6b0 in FilamentMonitor::Spin() ()
    #1 0x000be218 in RepRap::Spin() [clone .part.0] ()
    #2 0x000c1148 in AppMain ()
    looks reasonable...

    I get strange readings from my attached thermocouple board, but i guess that's a topic for a different thread.



  • While i am happy with the build. There seem to be strange issues with the openocd debugger. It seems as if reset it not working properly or probably the watchdog is biting me. Is there a way to disable the watchdog?

    Also it seems as if M42 does create any pwm output on the good old duet 0.6 board?
    E.g. i can switch the pin with M42 P60 S1/M42 P60 S0. But trying to output a PWM with "M42 P60 S0.5 F60000" fails?


Log in to reply