Newbie. wifi connection issues with duet 2



  • Hello. So this is my first printer board upgrade. Im going to be installing it into my ender 5 plus. So while i print out the adapter plates to fit it in Im going through the board setup.

    Ive got the drivers installed and the board talking to my computer via YAT. Im following the dozuki procedure and im not having any luck at all connecting to my wifi network. It says that i cannot connect to a 5ghz connection and my att fiber router is a dual band. Im not sure if this is the issue or not but after putting the bard in idle then entering the ssid and password (which the board accepts) taking it out of idle just gives me the no network connection error...

    I also tried connecting to the wifi at my job and same thing. I dont know what sort of connection it is there but I this board really this sensitive to connection type? Im assuming its just that im new to setting it up. Any help would be appreciated!


  • Moderator

    Does your wifi router have separate SSIDs for the 2.4 and 5ghz networks?

    If you send M587 by itself does it list your SSID?
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M587_Add_WiFi_host_network_to_remembered_list_or_list_remembered_networks

    Can you post the results of M122?



  • Unfortunately it does not provide different ssid's... It may have a way to direct specific ip addresses to the desired band but im not sure how i would go about that. (not the most savvy with the 192.168... gateway menu) Plus i would need to know the ip and mac address of the duet... is there a way i can find that?

    Also when i send the M587 command it does list my network... ive tried with the name for it and using the ip address... ill post that result and the m122...

    Im at work currently so ill be trying again from here today.

    Capture.PNG

    m122.PNG


  • Moderator

    I'm not familiar with that router at all, but if it's using a merged name for both bands the duet may be having trouble getting connected to the 2.4 band. If you can get the router to split the names that would be easiest then you can just connect directly to it. Otherwise you'd need to tell the router that the duet client should use 2.4.



  • Ok so for ATT users not familiar with networking settings.... in your IP gateway the option for advanced settings is a small blue link at the top of the home network/ wifi page. And thats where you can separate the 2.4 and 5 ghz bands with separate ssid names.

    Worked finally! Separating the bands into two separate networks was the key.


Log in to reply