Fallen at the first hurdle . fixed.



  • So just got my duetwifi. Installed the USB driver, connected it via USB.

    It shows as Bossa Program port COM5 in device manager and won't connect via pronterface in windows 10.

    I tried updating the driver manually and used the "browse my computer for driver software" option to manually select "duet 3d printer control electronics" driver downloaded in raw mode from github.

    It changes to "duet 3d printer control electronics" in device manager but still won't connect in pronterface.

    If it helps I've got two red LED's either side of the USB port on the duetwifi, then a green LED on the right of the bank of LED's and a red one to the left of that.



  • I've also tried the procedure in https://duet3d.com/wiki/Updating_main_firmware under backup method 3.
    I uploaded successfully the DuetWiFiFirmware-1.15c.bin from DC42's github repository, but no change.



  • So I tried method 3 again and now its working, I possibly did not press "boot from flash".


  • administrators

    I'm glad you got it working. It sounds as though your board somehow got erased after being tested - it shouldn't announce itself as Bossa Port unless the Erase button is pressed.



  • I think I worked out what was doing it. The front panel I remixed from your one on thingiverse was pressing the erase and reset switches. So what I've done is to cut away that section of the panel, which now rather than being a risk of pressing the erase button, actually protects them from being inadvertently pressed. Now there is just a long slot cut-away from the usb port past the reset/erase and along to the bank of LEDS.

    Now just to see if all this erasing and resetting at random can be recovered.



  • Yes using the Sam BA v2.16 method works and the board is now behaving normally.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.