WiFi Settings Help Please



  • I recently updated to more recent firmware on my Duet wifi 102 board (Firmware 2.05.1 and Wifi server 1.2.3) and I could not connect via DWC reliably so I followed the relevant .dozuk docs to try and solve it.

    I could communicate via YAT and when I followed the set up procedure it reacted as expected and the Blue WiFi light would stay on when the WiFi was enabled but for some reason I still couldn't connect via DWC. Then for some reason during the process the WiFi LED would not switch on.

    I then tried the stage 1, 2 and even 3 (erase), solutions in Duet WiFi documentation without success (but I did get back to where I was before). I also reverted to a known good SD card with earlier software with no change.

    What happens now is the Wifi module light flashes when first switched on and it also flashes when I update the WiFiserver.bin via YAT using M997 S1 but does not come on to a steady state when I enable via M552. The WiFi set up using M552 and M587 commands work as expected but after entering the SSD and pass word in M587, M552 returns an error message that there are no known networks.

    One thing that may or may not be relevant is that even when I did an erase and uploaded the bin file, I could still see remembered WiFi SSDs when sending M587, I expected this information to be erased?

    Here is the Wifi section of M122:

    • WiFi -
      Network state is changing mode
      WiFi module is idle
      Failed messages: pending 0, notready 0, noresp 0
      Failed to get WiFi status
      Socket states: 0 0 0 0 0 0 0 0
      ok
      Error retrieving WiFi status message: bad reply format version
      WiFi module is idle
      WiFi reported error: no known networks found
      WiFi module is idle
      *(The error is repeated many times and I am not sure what changing modes means.

    I accept that this problem might be of my own making but any help would be appreciated.

    John S


  • Moderator

    Try M588 S"*" to clear the remembered wifi networks and then add it again.

    They are stored separately and do not get cleared when updating the wifi server firmware, which would be annoying to have to re-enter every time you update.

    If you send M122 does it confirm that you are using firmware 2.05.1 and wifi server 1.23?



  • Thanks for a quick reply
    I did try M588 . to remove stored networks but only once not twice, I removed them individually.
    Good point, I can see the firmware version but cannot see the wifi server after running M122. (should it all be shown on the first line?) It did go through the motions of installing it with M997 S1 using YAT and it showed the progress and reported it was successful.



  • M122 results for firmware &WiFi section, it shows 1.23 is installed:

    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later

    • WiFi -
      Network state is running
      WiFi module is idle
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address 98:f4:ab:dc:54:41
      WiFi Vcc 3.31, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 30176
      Socket states: 0 0 0 0 0 0 0 0
      ok

    Thanks


  • Moderator

    Please download this bin file and place it in the /sys folder on the SD card and then try running M997 S1 again.

    https://github.com/Duet3D/RepRapFirmware/releases/download/3.0/DuetWiFiServer.bin

    Perhaps the version on your SD card currently is corrupt in some way or isn't being flashed properly. Trying to flash it again with a fresh file may help it recover.

    To simplify the wifi troubleshooting you may want to check out these 3 wifi macros at the bottom of the list here: https://github.com/x0rtrunks/RRF-Example-Macros/tree/master/macros/Diagnostics



  • I tried the file you suggested but unfortunately it didn't solve the problem. After starting from scratch and methodically going through the firmware install procedure again I noticed that the diag. led was staying on when expected it to be off. Fearing I had corrupted the board, I decided to try installing RRF3 as a last resort. Low and behold it worked!

    I am now converting my config.g file,
    so far its not as arduous as I thought.

    Thanks again for taking the trouble to reply, to be able to contact someone with your knowledge is invalable.

    John S


  • Moderator

    Are you saying the wifi is now working?

    @jmshep said in WiFi Settings Help Please:

    I decided to try installing RRF3 as a last resort. Low and behold it worked!



  • Hi jmshep !
    I think I have the same problem as You. What is the " RRF3" You mentioned? I have already spent one day with this wifi problem without success.


  • Moderator

    @Pertti RRF3 is reprapfirmware version 3 as opposed to version 2. Though I'm not aware of any changes that would affect wifi function between the two.

    I suggest you start a new thread with your specifics.


Log in to reply