No way to re-install firmware works!



  • From the very beginning was not able to connect to the WIFI interface on my duet 2 WIFI
    So I decided to install a new firmware!

    Tried to install SAM-BA (Not possible on my MAC nor Windows PC due to restrictions)
    Tried to install YAT (Same issues)
    Finally converted one of my MAC books into LINUX UBUNTU (There I was able to install SAM-BA but could not get the USB connection to work)

    Since all of this did not work, I erase the installed firmware and to install a new firmware over the SD card. I have copied all the files to the SD card as instructed. Powered up the card and nothing happened.

    I can see the USD interface:
    Christians-Mac-mini:~ christianwitsch$ ls /dev/tty.*
    /dev/tty.Bluetooth-Incoming-Port /dev/tty.ChristiansiPhone-Wirele
    /dev/tty.ChristiansAirPods2-Wire /dev/tty.usbmodem14201

    But when I try to access the card I get a blank Terminal!
    screen /dev/tty.usbmodem14201 115200
    Gives me a white screen!

    I can also not send the M997 S0 to install the firmware commend!

    What to do?

    Anybody can help?


  • Moderator

    @Cwitsch use bossac on Mac, and see this thread: https://forum.duet3d.com/topic/11445/flashing-firmware-on-mac-os-x

    Edit: once you get bossac working, follow Bossa instructions here https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Fallback_procedure_Num_3

    Edit2: if you have erased the firmware by pressing or jumpering erase, there’s no firmware, so no way for the Duet to read the firmware off the SD card. At that point, you HAVE to use a programmer like bossac. I haven’t managed to get SAMBA to work on Mac or Linux, but works fine on Windows, though I’ve always found Bossa easier.

    Edit3: use fixed version of Bossa here: https://forum.duet3d.com/post/166685

    Ian



  • Thank you droftarts for the information!
    As a simple user, it feels a bit scary to have to install software which might do what ever to my computer. Eg brew

    Would be great to have a firmware update tool which works as a registered and approved Apple software.

    I deleted the firmware and tried to install it with the SD card. Also having issues.

    Getting more and more to the point to scrap the card.



  • I try the path with a stand alone Linux Ubuntu PC. Just to contain the risk a bit.
    I had to install the curl program first.
    Also I had to install Git first.

    After all of this I could still run only the older version of SAMBA and again did not see the USB connection to upload the firmware.



  • Is there a command for Linux which is similar to the
    ls /dev/tty.* in the MAC terminal?


  • Moderator

    @Cwitsch lsusb usually does this. Please post in your original thread, using Linux is off-topic in this one.

    Edit: I’ve moved your posts back to this thread.

    Ian


Log in to reply