CORS Request Failed - Issue Uploading GCode



  • Hello,

    Recently one of my printers has failed in receiving gcode uploads.

    Info:

    Duet Web Control 2.0.0-RC3
    Electronics: Duet WiFi 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.02(RTOS) (2018-12-24b1)
    Duet WiFi Server Version: 1.22

    Web Browser: Google Chrome

    Issue:
    Whenever I try to upload a new gcode file (regardless of size) the upload process will start and then freeze somewhere around 6%. Then the error message:

    "Failed to upload [gcode-filename]"
    "CORS request failed"

    The files I try to upload range from very small (1.65MB) to large (88.8MB) and always get the same error. These files also upload without issue to other similar duet setups which sit next to eachother on a shelf. Additionally I can download files from the printer over DWC just fine (tested gcode + sys files)

    The SD card is 16GB, and when plugged into my computer is able to upload/download fine. I reformatted the card and reuploaded the files. I tried another SD card (4GB), it also works fine when plugged into my computer, DWC on the printer loads fine and I can control it, but I still cannot upload files.

    Any help would be appreciated 🙂



  • please update to the at least 2.0.5.1
    also release candiates are not supported after final release.
    please update that as well.



  • Thank-you, updating the firmware fixed the issue


Log in to reply