z axis not working no movement at all



  • Hi all
    Looking for more help. I have a buffalo cnc router running duet2 wifi and my z axis wont move. I have movement in y and x axis. I am just testing out the connections and making sure all axis move. for some reason z is not. I have rewired and checked all connections again still no movement on z so i changed the stepper motors over and plugged the z axis motor into x and the motor moves so, that says to me that the wiring is ok, the motor is ok, so must be a config problem? could anyone help please



  • @kesser71

    post you config.g

    i assume there is no error in the console



  • you have the jumpers on the secondary z header if only using one z motor?



  • Configuration file for Duet
    ; executed by the firmware on start-up
    ; Buffalo Firmware Version 1.0.7

    ; Configure Connection - ENABLE ONLY ONE OF THE BELOW THREE
    M552 S1 ; Enable Wifi Network
    ;M552 S2 ; Enable Access Point Mode
    ;M552 S1 P192.168.2.14 ; Enable Ethernet - Change IP Address to suit

    ; - - - - - - - - - - - - - - - - - - - -

    ; DO NOT CHANGE ANY OF SETTINGS BELOW
    ; TO MAKE A CHANGE, COPY THE LINE OF CODE, PASTE IT INTO customconfig.g. THE CHANGE CAN THEN BE MADE IN customconfig.g
    ; ANY ADDITIONAL SETTINGS SHOULD BE PUT IN customconfig.g

    ; General preferences
    M453 ; Put the machine into CNC Modes
    M550 PBuffalo CNC Machine ; Set machine name
    G90 ; Set absolute coordinates

    ; Network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Configure Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1:3 Z2 ; Apply drive mapping to axes

    ; Configure Axes
    M92 X400 Y400 Z400 ; Set steps per mm
    M350 X16 Y16 Z16 I1 ; Configure microstepping
    M566 X500 Y500 Z500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X2500 Y2500 Z2500 ; Set maximum speeds (mm/min)
    M201 X150 Y150 Z150 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2400 I100 ; Set motor currents (mA)

    ; Configure Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X347 Y278 Z105 S0 ; Set axis maxima

    ; Configure Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops

    ; Other Settings
    M140 H-1 ; Disable heated bed
    M564 S1 H1 ; Disable jog commands when not homed
    M911 S21.0 R23 P"G91 G1 Z3 F1000" ; Configure power loss resume
    M501 ; Load Stored Parameters
    M98 Pcustomconfig.g ; Execute custom config settings



  • Looks okay, so unless the jumpers are missing, the simple solution could be to use the 5th driver for Z;

    change

    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1:3 Z2 ; Apply drive mapping to axes
    

    to

    M569 P4 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1:3 Z4 ; Apply drive mapping to axes
    

    and connect z motor to E1 motor output (making sure to only connect and disconnect motors with the power off)



  • Fantastic. Thank you so much, that has worked. I just know i gonna have more question. T
    hanks guys and girls



  • (If its a new board you might want to determined if the Z driver has failed and have it replaced under warranty - and use E1 while you wait)



  • That i did think about but i know the company that supplied me with machine and card has gone under due to covid-19 thats what his email said. so my next question is do i need to change anything so my limit switches will work on z axis?



  • Sorry to hear about that, hopefully the E1 driver will not give you any trouble.

    As for the Z endstop, you don't need to move/change anything for that.
    (In fact, unless you're running RepRapFirmware 3.x you can't change it)



  • @kesser71 said in z axis not working no movement at all:

    customconfig.g

    please post the content of this file as well



  • ok don't have to change anything form limit switches thats cool. Next problem. when i go to home X i get a 5mm movement from z then a 5 mm movement from X, the same with Y axis a 5mm movement from Z then 5 mm movement from Y, and when homing Z just a 5mm movement. Any help please



  • thats controlled by the homeall.g, homex.g, homey.g and homez.g files.

    its normal to raise the z before homing x and y to avoid dragging on any stock if present.

    but you shoud get more than 5mm on x and y, they should move to the endstop and stop; odds are endstops are inverted?

    maybe this helps?

    edit:
    👇 ...you people... 💓


  • Moderator

    When and where did you purchase the board? If it was from an authorized dealer who is no longer around we would still honor the 6 month warranty.



  • it was bought from a company called Buffalo cnc on 19th august 2020. It is a router that come as a flat pack with a duet2 wifi board.


  • Moderator

    I'm unable to find Buffalo CNC on the authorized reseller list.

    https://www.duet3d.com/GenuineResellers

    Do you have a link to their website? If it still exists?

    Can you post a photo of the board?



  • I believe buffalo cnc are part of ooznest. Here is a picture of our board.
    Many Thanks9212cc8a-5753-4f98-b8a9-2c37de456bb5-image.png



  • is this an official board or will i need to buy a new one please??



  • @kesser71 said in z axis not working no movement at all:

    is this an official board or will i need to buy a new one please??

    post the backside of the board.


  • Moderator

    Sorry I missed your post with the photo, checking now.


  • administrators

    @Ryan-Lock recognise this board?



  • Thanks for tagging me @T3P3Tony. I can confirm Buffalo CNC are Not related to Ooznest in any way. The connectors on that Duet have a yellow tint, ours do not look like that.


  • administrators

    Thanks for the confirmation Ryan.


  • Moderator

    @kesser71 Can you provide full photos of both sides of the board?



  • Thank you guys for looking into this for me. I was lead to believe this was part of ooznest my apologies to Ryan. Here is a photo of the back of this board and now seeing the small print i fear that this is not an official one. If i need to purchase one i will do, where do i get them from? Are they are avalible? and how much are they.
    many thanksthumbnail.jpg



  • @kesser71

    its a clone. the text at the bottom has to be included on a clone.


Log in to reply