Virtual Heater problems with latest firmware and DWC



  • I'm trying to set up virtual heaters with firmware 1.19.8 and display them on DWC (1.17) but am having problems.

    I monitor various thermistors that are stuck around the machine and use these temperatures to control fans. Up until now, I've defined "dummy" tools to display these temperatures. So for example I have M305 P2 T100000 B3950 R4700, then M563 P99 H2. Now I want to make use of the virtual heaters to display the temperatures, instead of having a long list of "dummy" tools, but I'm obviously doing something wrong because I can't get it to work

    I changed the above line to be M305 P103 X2 S"Duet" T100000 B3950 R4700 which according to this https://duet3d.com/wiki/G-code#M305:_Set_temperature_sensor_parameters looks right. I also commented out the M563 P99 H2 line. But DWC doesn't display the new heater in either the heaters tab or the extras tab. Also, it still displays Tool 99 but with a temperature of 2,000 deg C. I can get rid of that by going into settings and manually deleting the tool. I tried closing down Firefox then re-opening it but that didn't work. I also tried deleting the recent history in Firefox but that didn't work either.

    No doubt, it's me doing something stupid - just don't know what.

    Ian


  • administrators

    Please try beta 9. The use of the S parameter to name a heater in the M305 command doesn't work in earlier versions.



  • OK will do.

    Trouble is I can't load any firmware right now. Doing it through DWC seems to work but after it's uploaded I just get a message to say it can't connect, then I have to cycle the power to the printer. After which it connects OK but reports the same firmware version as before the update. Tried putting the latest iap4e file in sys and doing it through pronteface but that doesn't work either.

    I'm really reluctant to try the Samba route as, from what I've read, I have to erase the firmware completely. The printer is working OK right now and there are a lot of other things that I need to do to it as I have a certain deadline to meet and not much time to get everything done.

    Is a complete erase and start afresh the only option?



  • Update. As the "S" parameter is optional, I quickly edited config.g with the M305 P103 X2 Tnnn etc etc but wothout the "S" parameter, and commented out the old tool 99 that used heater 2. After rebooting, the old tool disappears from the list as expected but I can't see heater 103 anywhere. Neither in the "heaters" tab nor in the "extra" tab.


  • administrators

    Only named virtual heaters appear in the Extra temperature list in DWC. Anonymous virtual heaters can still be used to control fans.

    In firmware beta8 you can use the H parameter to define the heater name instead of S.

    After erasing the firmware you can use either SAM-BA or Bossa/bossac 1.8 to upload firmware via USB. I have been using Bossa recently.



  • Ah OK. I'm getting the hang of this now. So with beta8 and using M305 P103 X2 H"Duet" the virtual heater shows up in the extra tab just fine. I understand that from beta 9 onwards the H parameter is replaced with an S parameter.

    For Heaters to show in the heater tab, they must be assigned to a tool or the bed (which makes sense, otherwise they aren't heaters.

    That's all made my interface look much cleaner - many thanks.

    I appreciate that this is all experimental beta stuff but when it's finalised, may I suggest that the wiki is updated to show that the name parameter is essential in order for virtual heaters to be displayed on DWC. Currently the wiki just states that the name parameter is optional.

    Just out of curiosity, is there a maximum length for the virtual heater name? I'm using names like "LowerLeftXYStepper" and "UpperRightXYStepper" which all work fine but I just wondered if there is a character limit and also if any special characters like slashers, commas, brackets and so forth should be avoided.

    Ian


  • administrators

    There is no limit on the length of a heater name at present, although DWC might not be able to display very long names, and there is an overall limit on how long a line of GCode can be (100 characters AFAIR).

    I've updated the M305 documentation.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.