DWC won't connect



  • DWC comes up, but says "disconnected". I cannot interact with any of the local files, however the printer will home when i hit the home all button, but nothing else works like it's connected. The printer pings, and upon checking the panel, everything seems to work correctly. I have checked the network and everything appears nominal. I have not changed anything and it was just working literally yesterday. Any ideas would be appreciated as i'm under the wire to get this project out (perfect timing for the duet to eat sh!t).

    Thanks for the help in advance. ;-D



  • I have partially 'fixed' the issue. Basically something is biffed within firefox 84 and the DWC interface. Shutting down all extensions and add-ons does NOT resolve the issue. However it will run in a private browser (even with addons).... WTF it's problem is is beyond me at this juncture, but still rather irritating that i have to open whole new windows, rather than just keeping it in my current tab structure. Still looking for a fix.


  • Moderator

    DWC version?



  • Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.03 (2019-06-13b2)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6


  • Moderator

    I suggest you update your firmware and DWC to the latest for RRF2. 2.05.1. No changes needed to the config.g.

    Just upload this zip file as is (don't extract it) to the system tab in DWC.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/Duet2Firmware-2.05.1.zip



  • will check it out after this project is complete and report back on the outcome.



  • I literally did nothing, and DWC started working again. <facepalm> I tried everything yesterday to get it to work, turned off all the addons, restarted, checked network, etc etc. Today, i fire up the printer and it just works again. i dunno wtf got it to fail yesterday. And I can't get it to reproduce again today. I'll put it down to weirdness with firefox i guess.

    Thanks for the advice. I'll be done with this project soon and i'll suck it up and upgrade my firmware.


Log in to reply