DWC question.



  • Hi,

    I am using the most recent firmware and all is working well.

    I have installed a Diamond 3 on my system and to keep the wiring tidy I connected all three extruder motors to the Duex 5 board leaving the normal extruder driver outputs on the Duet Wifi unused.

    Yet these drivers still display on the DWC pages.

    Anyway to hide them?

    Thanks.

    Frederick


  • administrators

    You can use the M584 command to have extruders 0,1,2… be on drives 5,6,7... or whatever you want.



  • @dc42:

    You can use the M584 command to have extruders 0,1,2… be on drives 5,6,7... or whatever you want.

    OK I will give that a try.

    Thanks much.

    Frederick



  • Hi,

    Just a bit confused.

    To make the three extruders use the first three drivers on the Duex 5 board I would use:

    M584 E5:6:7

    I'm assuming drivers are numbered from 0-4 on the main board and 5-9 on the expansion board.

    Yes? No?

    So now when specifying steps/mm for extruders using the M92 command do I use M92 90:90:90?

    Before using M584 I needed to use M92 with dummy values for the first two parameters like this M92 10:10:90:90:90.

    And when specifying tools there is a driver number parameter - it seems that I must use 0, 1 and 2 instead of 5, 6 and 7 as used in the M584 command.

    I find that somewhat confusing - driver numbers don't appear to always map to the physical drivers on the boards.

    Perhaps you can clear things up for me.

    Thanks.

    Frederick


  • administrators

    That's all correct, except I think you meant M92 E90:90:90. The M584 command maps (in this case) extruder drives 0, 1, 2 to driver numbers 5, 6, 7.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.