Error: Heater 0 fault: heater monitor 0 was triggered



  • Here is my updated config.g. Tuning is still in progress, so I haven't restarted the board to apply the new settings yet.



  • ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.2.0 on Sat Jan 02 2021 15:54:53 GMT+1100 (Australian Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Black Widow" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S1 ; enable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1000.00 E420.00 ; set steps per mm (z was 4000)
    M566 X900.00 Y900.00 Z60.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X370 Y250 Z300 S0 ; set axis maxima
    M208 X-205:165 Y-140:110 ; set axis limits

    ; Endstops
    M574 X1 S1 P"!xstop" ; configure active-high endstop for low end (or high end?) on X via pin xstop (was M574 X1 S0 P"xstop")
    M574 Y1 S1 P"!ystop" ; configure active-high or low? endstop for low end on Y via pin ystop (S0 = no endstop) ;if you are using RepRapFirmware 3 then you will need to use S1 but invert the polarity by putting a ! character at the start of the pin name in the M574 command
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X48 Y-18 Z3.8 ; set Z probe trigger value, offset and trigger height
    M557 X15:355 Y15:235 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S135 ; set temperature limit for heater 0 to 135C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P1 S0 H-1 ; set fan 1 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P0 T45 H1 ; set fan 0 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Extruder" D0 H1 F0 ; define tool 0;
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue

    M501 ; load values stored in config-override.g



  • How long does the new tuning algorithm take? It seems to be hovering around 80C atm,. I told it to tune to 120C.



  • Should I reset and start the tuning again? It still says it is running.

    1/14/2021, 11:51:57 AM Upload of config.g successful after 0s
    1/14/2021, 11:50:19 AM Upload of config.g successful after 0s
    1/14/2021, 11:40:18 AM Auto tune starting phase 1, heater on
    1/14/2021, 11:40:13 AM M303 H0 P0.4 S119
    Auto tuning heater 0 using target temperature 119.0°C and PWM 0.40 - do not leave printer unattended



  • I grew impatient and reset the printer. I then sent the following:
    M303 H0 P0.4 S120

    I'll wait without changing anything now.....



  • Hmmm, I seem to have this error when doing the Autotune:
    1/14/2021, 12:34:32 PM Auto tune cancelled because target temperature was not reached
    1/14/2021, 12:04:32 PM Auto tune starting phase 1, heater on
    1/14/2021, 12:04:26 PM

    I'm not sure if it is related or not to my original issue. I'll try turning the bed heater on now with a 120C target.



  • No issues getting to, or maintaing the bed at 110C, which is what I ended up commanding the printer to do. I'll try printing something now and see if there is any change in the errors after the FW upgrade.



  • This is the heater graph now, while the printer is printing a calibration cube.

    6f02b6d1-943e-422f-b606-c77e18728998-image.png
    As you can see the temperatures are fairly constant according to the graph, which is how they were before.
    The big difference this time, is that the bed heater error hasn't occured (yet).


  • Moderator

    @dmbgo said in Error: Heater 0 fault: heater monitor 0 was triggered:

    How long does the new tuning algorithm take? It seems to be hovering around 80C atm,. I told it to tune to 120C.

    It can take a long time.


  • Moderator

    @dmbgo said in Error: Heater 0 fault: heater monitor 0 was triggered:

    M303 H0 P0.4 S120

    Why did you reduce the PWM factor so much?



  • @dmbgo said in Error: Heater 0 fault: heater monitor 0 was triggered:

    Hmmm, I seem to have this error when doing the Autotune:
    1/14/2021, 12:34:32 PM Auto tune cancelled because target temperature was not reached
    1/14/2021, 12:04:32 PM Auto tune starting phase 1, heater on
    1/14/2021, 12:04:26 PM

    Autotune didn't work, the second attempt at autotune led to the error above, however printing with the heatbed PID settings from an earlier firmware version that did successfully autotune, I have not experienced anymore heatbed errors.
    Given that the errors were very constant, I think that it might be fixed.
    Thanks!



  • Oh and the reduction of the PWM factor was from the example at:
    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control


  • Moderator

    Yes the previous tuned values should still be valid.

    I would try tuning again with full power to see if it has better luck hitting the commanded temp.


  • Moderator

    It's just an example of how the power factor can be used. Normally you'd want to tune at full power. I'm going to change that example. Actually I don't see that example at all in that tuning link, but I did find it in the M303 entry in the gcode wiki and have changed it to use 100%. The only times you'd want to use that is with an overpowered heater that is throwing "heating too fast" errors.



  • That makes sense Phaedrux. I was wondering why it was 40%. Given that the errors seem to have gone after the FW update, and the bed is stable, do you see any reason not to move on?


  • Moderator

    Nope, I think you're good to go.



  • Thanks for your help.


Log in to reply