SOLVED Tool offset setting bug: U axis skipped or omitted.



  • While running a macro to test the limits of the tool-offset variable workaround I ran into this problem.

    Macro:

    M563 P10 S"data"
    G10 P10 X0 Y1 Z2 U3 V4 W5 A6 B7 C8 D9
    echo {tools[10].offsets[0]}
    echo {tools[10].offsets[1]}
    echo {tools[10].offsets[2]}
    echo {tools[10].offsets[3]}
    echo {tools[10].offsets[4]}
    echo {tools[10].offsets[5]}
    echo {tools[10].offsets[6]}
    

    This seems to work as expected, however it seems the U axis is missed in some way with the W axis taking its place.
    Here is a screenshot of the OM browser after running this macro and refreshing:

    Screen Shot 2021-02-15 at 11.02.33 AM.png

    I believe this is a bug as axes are in the order XYZUVWABCD.
    Thanks,
    T


  • Moderator

    Firmware version?



  • 3.3beta1


  • administrators

    The axes will be numbered in the order that you created them. So we need to see your M584 command. It also matters that the M584 command is earlier in config.g than your G10 command, so that the U axis already exists when you run G10.



  • Got it, thanks.
    I was using the U axis for auto Y squaring and was defining it in a separate command than the main M584 for hiding purposes.
    Solved now.


Log in to reply