New Duet WiFi user : Need help with initial firmware setup…



  • I have been attempting to get the Duet WiFi up and running this week with little success. After struggling initially with getting the board to connect, I ended up hitting the erase button and had to start from scratch. I decided to install 1.19RC5 per David Crockers suggestion in another thread (https://www.duet3d.com/forum/thread.php?id=2220).

    I will list the steps I took to install the new firmware and where I have hit a roadblock below. Any and all help would be greatly appreciated!

    Downloaded Windows Drivers (dc42)

    • Duet.inf
    • Duetinf.cat
      Downloaded dc42 fork of RepRap Firmware
      Connected Duet WiFi via USB cable
      Checked on Device Manager and the board registered as Bossa Program Port (COM6)
    • Updated Drivers
      Downloaded Bossa V1.8
      Open Bossa
    • Connected to COM6
    • Open dc42 firmware
    • Open Release folder
    • Duet WiFi
    • 1.19RC5
      Set Bossa to "Erase All", "Boot to Flash", then "Write"
      Firmware successfully written to board
      Exit bossa
      Tried connecting Pronterface, but failed.
      Reset Board
      Check Device Manager
    • Board now shows up as "Duet WiFi or Duet Ethernet 3D Printer Control on COM7
      Reconnect to Pronterface with Success on COM7 @115200 baudrate
      Plug SD into laptop
    • Copy dc42 SD image to SD card
      Open 1.19RC5 Update Notes
      View Ormerod 2 /sys folder and opened config.g file in notepad++ to look at start up code
    • Copy dc42 DuetWiFiFirmware-1.19RC5 to Ormerod 2 sys folder
    • Rename to DuetWiFiFirmware.bin per update notes
    • Extracted DuetWebControl-1.17+2 into "www" folder on SD card
    • Copy dc42 DuetWiFiServer-1.19Beta10 to Ormerod 2 sys folder and rename to DuetWiFiServer.bin per update notes
      Used Notedpad++ to write macro suggested in update notes and stored in the macro folder
      Used Notepadd++ to comment out M552 per update notes
      Reconnected to Pronterface successfully
    • Sent M997 S0:1, M997 S1 and M997 S2 with no success.
    • Pronterface send back error message saying the .bin file cannot be found.

    This is where I am stuck….


  • administrators

    You don't need to run M997 S2 any more if you are running 1.19 series firmware. Please do the following:

    • Send M115 from Pronterface and see what version of firmware it reports. If it reports 1.19RC5 then you are running the correct main firmware.
    • Run M552 S0 to enable the wifi module but not WiFi
    • After a few seconds, run M552 with no parameters to get the wifi status. It should be idle. In which case:
    • Run M122 and look at the wifi firmware version it reports, It should be 1.19beta10. If so:
    • Run your macro file to try to connect to the access point After a few seconds it should report success, or you may see an error message.


  • I sent M115 and it confirmed 1.19RC5 firmware. Which is good!

    • I ran 552 S0
    • When I ran 552, I got back "wifi module is being started", "wifi module started" and then "Error: Failed to initialize wifi module, code -10".
    • I then ran M122 and it reported the main firmware, 1.19RC5.

    Also, how do I run the macro file?

    Thank you for your help!


  • administrators

    Copy the DuetWiFiServer-1.10beta10 file to /sys on the SD card in a PC and rename it to exactly DuetWiFiServer.bin. Put it back in the Duet, start the Duet, and send M997 S1 from USB or PanelDue. It should give you progress updates and eventually report success. When it does so, try running M552 S0 again.

    To run the macro file, send:

    M98 P/macros/filename

    assuming you put it in the /macros folder, substituting whatever you called it for "filename".



  • I did exactly what you suggested and I still get a message on Pronterface stating that DuetWiFiServer.bin not found



  • The only 3 files that I have on the SD are :

    • DuetWiFiFirmware.bin
    • DuetWiFiServer.bin
    • iap4e.bin

  • administrators

    Can you confirm that you put those files in the /sys folder of the SD card, not in the root?



  • I created a new folder, named it sys and put the files in it. Is there another way to make sure they aren't saving to the root?



  • once the files are in the sys folder you need to run the m997 command to flash it. Right?

    m997 s0:s1

    I think is the command to do both.

    Wait about 1 minute

    (copy of DC42's comment)



  • When I was trying to update mine from pre 1.18 I noticed my DuetWiFiFirmware.bin file kept getting deleted whenever I tried to run M997 S0 in Pronterface. My saving grace was to make sure I had the firmware.bin file in the sys folder and use PanelDue to run the command properly.


  • administrators

    The DuetWiFiFirmware.bin file gets deleted from /sys after is has been successfully installed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.