Issues Flashing Duet



  • Hi! So earlier today I had inexplicable connection failure with my Duet Wifi. No wifi connection, no USB connection. I followed the instructions here: https://duet3d.com/wiki/Updating_main_firmware and tried to use the erase button + reflashing with SAM-BA.

    Everything goes smoothly until I after I send the .bin. When I hit "Compare sent file with memory" it tells me there's no match. When I 'Boot From Flash (GPNVM1)' I get told it failed. Either way, the duet becomes completely undetectable to either the windows computer or my mac. I have to hit the erase button to get it to register in the COM ports.

    I've tried 1.19 and 1.18 Firmwares and SAM-BA 2.16 + 2.17. I've also tried running the program as admin in compatibility mode, something mentioned in another thread here. Any help would be greatly appreciated!


  • administrators

    It could be a power issue. Assuming you are flashing the firmware using USB power only, disconnect any other devices that are drawing power from 5V or 3.3V e.g. PanelDue, Zprobe, active endstops. Also unplug the PSU from the mains even if the PSU is switched off, in case it is a USB ground loop issue.



  • Hi! Thanks for the suggestion. I am running on USB power, I tried everything you wrote, but no luck.

    I saw that BOSSA is now compatible so I tried using that via my mac. I get about 5% into writing the file before I get a failure.


  • administrators

    In that case, it sounds like the processor has failed. Is it getting hot?



  • Yep, now that you mention it, it's burning up!


  • administrators

    Any idea what caused it? Can you see any damage to the 3.3V regulator IC, labelled U2 on the PCB, or to any other ICs?



  • Hmm, no damage to U2 and all the IC's look fine, as far I can tell. I'm still getting the normal array of LEDs when powered. It happened in between prints, but there wasn't any smoke/smell. I'm at a loss, but it's definitely non-responsive.


  • administrators

    How old is the Duet WiFi, and which country are you in? Which revision PCB is it: 1.0, 1.01 or 1.02 ?



  • I got it with the d300vs kit from ultibots in july. I'm in the US and it's 1.02.


  • administrators

    Please ask Ultibots for a replacement Duet under warranty. They have been in touch with us and we will approve it.


Log in to reply