Unable to install firmware on new board - SAM-BA Error



  • I'm building a new printer and I'm having no success installing firmware on the Duet Ethernet. M997 only resulted in read/write errors and I could never get the ethernet connection to work; M552 would change the configured IP but actual IP stayed 0.0.0.0.

    Fast forward, I tried to erase the board and flash via Bossa with no success. I tried on both a Mac and a PC; each computer returns a "Auto scan for device failed" error. I even tried to specify the port on both the PC and Mac with the -p argument (COM3 and cu.usbmodem1421 respectively) with no luck.

    Following other threads in this forum I downloaded SAM-BA and gave it a try this morning, but I receive the following error after pressing 'Connect'


  • administrators

    Disconnect any devices form the Duet that draws significant power from +5V or +3.3V, such as PanelDue. Connect the Duet to a Windows PC via USB, load Device Manager, and expand Ports (COM and LPT). Do you see Bossa Program Port there?

    If no: press Erase again for at least half a second, then Reset, and see if it appears. Also look for other ports or unknown devices appearing in Device manager after you connect the Duet to the PC.

    If the port still doesn't appear, try a different USB cable.



  • Thanks for the fast response! Yes, have tried all these things including installing/re-installing every available driver (random troubleshooting at this point)

    There's nothing connected to the Duet except the USB cable and yes, when connected in Windows I see the Bossa program ports. If I press erase then reset, it will drop and reappear in Device Manager. I get the same result with two different USB cables.


  • administrators

    OK, you've got the Bossa port, so you should be able to program it using either SAM-BA or Bossa. Make sure you are using the 1.8 version of Bossa - earlier versions won't find the processor. Auto scan should find the Duet, but if necessary you can tell it which COM port to use, i.e. the one that shows up as Bossa port.



  • Ha. So I changed nothing, rebooted the PC, erased and reset the Duet and ta-da, SAM-BA is running. Maybe it just needed 20 erases to work? Thanks again for the quick responses.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.