Not booting or reading SD after update



  • Just upgraded to 1.19 per directions on my duet Ethernet. I have a panel due 5" as well and now no matter what I have tried the board does not appear to boot up. Device is detected by computer but no connection or port can be opened. I've verified all connectors are correct and good and tried multiple USB cables and I am still unable to connect too the duet. The panel due does shows connecting, then changes to starting up and just hangs and message does not change. I tested the SD card and have used multiple known good as cards and the issue persists. Note: I've been using 1.19 since beta 3 up through rc1 and then the final release.


  • administrators

    Does it boot up if you remove the SD card? It may take a little while before it gives up trying to read the SD card.

    Maybe the firmware image you flashed was corrupt. In that case you can download a new one and use SAM-BA or bossac 1.18 to install it.



  • It doesn't boot with the SD card removed either and can't get it to be detected when connected either to be able to re-flash it 😞


  • administrators

    When you say it is detected by the computer, what device does the computer display it as?



  • I can connect to it as long as I dont have an SD card installed. I was able to re-flash it but I can only connect to it if there is no SD card inserted. The temp probes are being read and manual motor control seems as though there is not enough power being applied to the stepper motors to move them. I have tried multiple different known good SD cards loaded with my last working configuration but as mentioned before it will not boot if an SD card is inserted.


  • administrators

    Does the green 3.3V Led go out when you insert the SD card?



  • it remains lit. A little update. I formatted the sd card and reloaded it with the default sd card files and renamed the sys-prusai3 to sys and the board now boots. However if I try to load my config created with the configuration tool it will not boot from the sd card. So as it is right now it will only boot in a usable state if it is loaded with a default config.g. I tried doing a print and despite being able to heat the bed and nozzle it seems confused as to what direction it is homing in despite the endstops working and triggering correctly via the indicated board lights for the endstops. I am using active high for endstops with x y and z being placed at low end but if I try to add the endstop config to the config.g it will not boot from the sd config (M574 X1 Y1 Z1 S1 ; Define active high microswitches). Also the ethernet module does not come online. Seems like it may be time for a warranty inquiry 😞



  • another issue I am having with it is that the z axis will not home. When selecting z home on the paneldue or in s3d the z axis moves in the opposite direction (up) and stops after traveling 50mm in the opposite direction of the z axis endstop. x and y homing works properly and goes to the endstop limit and stops.


  • administrators

    So it boots with the default config.g for the Prusa i3, but not with the one you generated. Try sending M552 S1, that should get the Ethernet interface working. If that works, try editing config.g in the System Files Editor in DWC. You could start by changing S0 to S1 or vice versa in the M569 P2 command, to reverse the direction of the Z motor.



  • @dc42 M552 S1 command get accepted then console reads out M105 ten times an then loses connection and reboots and ethernet interface does not activate.


  • administrators

    Then perhaps it is time for a warranty inquiry. Email your supplier.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.