Firmware 1.19+3 (1.19.1 release candidate)


  • administrators

    I've just released an update to firmware 1.19. the binaries an be found at https://www.dropbox.com/sh/wq0u70kpapqc3is/AAC6I8TS5Lbwuziq_r3M15Qea?dl=0. The changes since the 1.19+1 test version are:

    New features:

    • M37 P parameter is supported. If you send M37 P"file.g" then printing file.g will be simulated and the expected print time reported.
    • SCARA kinematic calculations have been speeded up
    • SCARA segments/second now defaults to 100
    • The machine name and the password in the M550 and M551 commands may now be quoted, optionally
    • If M104 T# is used and tool # is currently in standby, then its standby temperature will be set as well as its active temperature
    • When a file print completes, the total printing time is logged to the GCode console

    Bugs fixed:

    • Incorrect and very large height errors were sometimes shown in the G29 height map when the number of probe points used approached the maximum supported

    Please test this if you are brave enough, because I'd like to release this as firmware 1.19.1 within the next few days. The new P parameter on the M37 command is designed to make it much easier for you to simulate a print so that you know how long it will take.

    I hope to do a separate update to the WiFi module firmware for the Duet WiFi soon.



  • 1.19 + 3 test in progress
    For me everything is almost perfect,
    There remain some vibrations which must be improved with M669 Sxx Pxx
    And M566 currently I put M566 / 20 compared to M203 …



  • So far so good. M37 works well. I tested it on my 3 extruder test bed. Everything is as expected. Great job




  • administrators

    Looking good! What is the bed surface?



  • Also currently printing on my Machine with 1.19+3 without any kind of problems. Indeed it seems to fix the BedSurface-Problems cause i use over 200 Measure-Points. Now it looks much more real πŸ˜‰

    Also before with 1.19+1 i've noticed that Filament-Measurement isn't working well (800mm printed of 1700mm but finished) which seems to show now the real values.

    Cheers
    MoS-tekknix



  • @dc42
    The bed surface is PET Tape (Blue)
    Better adhesion to the kapton and much more rigid
    And good detection with IR Sense apparently
    Search "3d printer pet tape" on Google …



  • Working on my corexy, just trying it on the Kossel XL. The print simulator estimated 1hr17 for my first print on the corexy and it took 1hr20.


  • administrators

    @MoS-tekknix:

    Also currently printing on my Machine with 1.19+3 without any kind of problems. Indeed it seems to fix the BedSurface-Problems cause i use over 200 Measure-Points. Now it looks much more real πŸ˜‰

    Also before with 1.19+1 i've noticed that Filament-Measurement isn't working well (800mm printed of 1700mm but finished) which seems to show now the real values.

    Cheers
    MoS-tekknix

    Thanks for the feedback. Which figure do you think is correct, the 800mm or the 1700mm? Does that print use just one filament, or more than one? Are you using relative or absolute extruder coordinates in your slicer?

    I've just done a print and it finished with 1274.7mm of 1280.7mm, so it's working for me.


  • administrators

    @DjDemonD:

    Working on my corexy, just trying it on the Kossel XL. The print simulator estimated 1hr17 for my first print on the corexy and it took 1hr20.

    Thanks for the feedback! Did the 1h20 include heating time?


  • administrators

    @dc42:

    @MoS-tekknix:

    Also currently printing on my Machine with 1.19+3 without any kind of problems. Indeed it seems to fix the BedSurface-Problems cause i use over 200 Measure-Points. Now it looks much more real πŸ˜‰

    Also before with 1.19+1 i've noticed that Filament-Measurement isn't working well (800mm printed of 1700mm but finished) which seems to show now the real values.

    Cheers
    MoS-tekknix

    Thanks for the feedback. Which figure do you think is correct, the 800mm or the 1700mm? Does that print use just one filament, or more than one? Are you using relative or absolute extruder coordinates in your slicer?

    I've just done a print and it finished with 1274.7mm of 1280.7mm, so it's working for me.

    One more question: are you using volumetric extrusion?



  • @dc42:

    @DjDemonD:

    Working on my corexy, just trying it on the Kossel XL. The print simulator estimated 1hr17 for my first print on the corexy and it took 1hr20.

    Thanks for the feedback! Did the 1h20 include heating time?

    That could explain it. But I'd say within 3 minutes is a pretty good estimate.


  • administrators

    Also any other operations that take a variable amount of time are not counted: heating, cooling, homing, bed probing, and changing tools. It runs the gcode file and plans all the moves, except that at the last minute it doesn't actually do each move, it just works out how long it would take.



  • Received my DuetWiFi a couple of weeks ago, v1.18.
    Managed to upgrade to 19.1+3 using special instructions.
    Wifi works, configured 4 thermocouples ok.
    Will hook up to heaters, steppers, endstops and IR z probe over the weekend.

    Many thanks for all your hard work and documention.



  • Uploaded the firmware without any issues and printed 3 separate prints on a Ultibots D300VS delta printer.
    I did not run across any issues, Everything turned on and off when it was supposed to.



  • M37 P works really well, estimate was correct to within a minute.

    However, the firmware stopped automatically selecting Tool 0 if no tool is active. Meaning it just starts moving the head without activating the extruder if I start a print with no tool active.


  • administrators

    What do you have at the start of your gcode file? If there is a M109 command to set the hot end temperature, that should select the tool



  • I'll give this a go in the ormerod 2 before I strip it down. The Repeitier Host estimation was out by an hour for a four hour build, hence my interest in Simulation!

    Will all the 1.19.x releases work on the Duet 0.6?



  • still having major issues with file uploads, they never complete have to M999 to duet (WiFi signal strength -59dBm)
    also having the gcode issues I reported earlier
    edit: after ~10 tries, I managed to upload a 4MB gcode file… during the first tries a rpi was connected to the usb port of the duet (no software connection tho), for the successful try I disconnected it. Time will tell if there's a relation. If it happens again I'll either downgrade to 1.18 or replace the web ui by octoprint.



  • @dc42:

    @dc42:

    @MoS-tekknix:

    Also currently printing on my Machine with 1.19+3 without any kind of problems. Indeed it seems to fix the BedSurface-Problems cause i use over 200 Measure-Points. Now it looks much more real πŸ˜‰

    Also before with 1.19+1 i've noticed that Filament-Measurement isn't working well (800mm printed of 1700mm but finished) which seems to show now the real values.

    Cheers
    MoS-tekknix

    Thanks for the feedback. Which figure do you think is correct, the 800mm or the 1700mm? Does that print use just one filament, or more than one? Are you using relative or absolute extruder coordinates in your slicer?

    I've just done a print and it finished with 1274.7mm of 1280.7mm, so it's working for me.

    One more question: are you using volumetric extrusion?

    Yes, indeed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.