Z-Homing, Error: Z probe was not triggered during probing move



  • Hello,

    Found some time to upgrade to 1.19 today from 1.18.2 (I think, cant remember exact minor version number) after months or not finding time. Mainly for the dual Z motors auto levelling but first things first. Does it work as it used to? No. So ill start with getting it back to how it was.

    Homing X and Y works fine still, Z starts to move the bed up to the ir probe and stops way short. Its as if it has a soft limit.
    I have deleted the probe macros as per the upgrade guide so its is not that.

    G28 Z
    Error: Z probe was not triggered during probing move

    Any ideas? Im sure im being stupid but after hours of searching the forum i can t find anything other than being told to delete the deployprobe and retractprobe files, which was done right at the start.



  • Does your bed drop all the way to the bottom and hit another limit switch before raising to the IR probe?



  • no. it drops a tiny bit (2.5mm) as defined in the homing file(s) then moves up… but then never gets near the probe that is on the extruder head and just stops with that error: G28 Z Error: Z probe was not triggered during probing move.

    If i wve my hand under the ir sensor i can see in the web console that it triggers so the ir sensor is working, the bed just never gets up to it to trigger.



  • My messy homeall script:

    ; Relative positioning
    G91

    ; Lift Z
    G1 Z2.5 F3600

    ; Move towards all axes endstops (first pass)
    G1 X-999 Y-999 U999 F3600 S1
    ; Go back a few mm
    G1 X5 Y5 U-5 F3600
    ; Move slowly to axes endstops once more (second pass)
    G1 X-999 Y-999 U999 F360 S1

    ; Absolute positioning
    G90

    G91
    G1 Z-999 S1 F3600
    G1 Z3
    G90

    G30

    ; Uncomment the following line to lift the nozzle after probing
    G91
    G1 Z5 F100
    G90



  • https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md

    Scroll down to 1.19 and see if any of the

    Upgrade notes from version 1.18.2:

    apply to you.


  • administrators

    Have you deleted the deployprobe.g and retractprobe.g files as described in the 1.19 upgrade notes?

    The homeall.g file suggests that you have both a Z min endstop switch and a Z probe. This seems odd - have you? If not, see #1 at https://duet3d.com/wiki/Common_problems_and_their_solutions.

    The command G28 Z runs homez.g, not homeall.g.



  • Yes, they have been deleted. Followed the guide to the letter as far as i can tell.

    Running homez.g does the same thing. Bed never reaches the prob as if it was a soft limit of some sort.

    Incase it helps:

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0 + DueX5
    Firmware Version: 1.19.2 (2017-09-01)
    WiFi Server Version: 1.19.2
    Web Interface Version: 1.19



  • OK maybe my install is broken:

    When ever i try to make changes to any file like config.g, homeall.g, homez.g 9 times out of 10 i get:

    JavaScript Error

    A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:

    Message: TypeError: undefined is not an object (evaluating 'uploadRows[0]')
    URL: http://192.168.124.19/js/dwc.js
    Line: 7468:12
    Error object: {"line":7468,"column":12,"sourceURL":"http://192.168.124.19/js/dwc.js"}

    Maybe the upgrade did not go so well?



  • @dc42:

    Have you deleted the deployprobe.g and retractprobe.g files as described in the 1.19 upgrade notes?

    The homeall.g file suggests that you have both a Z min endstop switch and a Z probe. This seems odd - have you? If not, see #1 at https://duet3d.com/wiki/Common_problems_and_their_solutions.

    The command G28 Z runs homez.g, not homeall.g.

    What part suggests a min and max endstop? I only have an IR probe on Min (on the x carriage). I cant see where i have specified a max endstop.



  • I just ran M999, then homed X then Y, then moved Z up to just below the ir sensor then homed Z and it works fine. It is just failing to home Z when the bed is more than say 10mm away. It just gives up and states "G28 Z Error: Z probe was not triggered during probing move."

    So it is this bit that does not work at all anymore….

    G91
    G1 Z-999 S1 F3600
    G1 Z3
    G90

    So if i home X and Y and move the ir sensor to X150 Y100 then send a G91 for relative positioning then G1 Z-999 S1 F3600 to send the bed up to the zmin endstop (ir sensor on x carriage) it does not move. This may be why it worked before and not now is G30 has a probe movement limit (as it seems to )...as it is the G30 command that is genrating that error.

    Any ideas?


  • administrators

    G1 Z-999 S1 says you are using a homing switch. G30 says you are using a Z probe. Follow the link I gave in my previous reply and look at the sample homez.g file contents for the two different ways of homing Z.



  • Ok, removing the G1 Z-999 S1 has resolved it. Thanks!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.