CONSTANT AJAX disconnect errors



  • I can not stay connected to my DuetWifi for more that a few minutes without getting the following error:

    !Communication Error
    An Ajax error has been reported, so the current session has been terminated.
    Please check if your printer is still on and try to connect again.
    Error reason: timeout

    Approximately 25% of the time I am able to either click connect again, or reload the page and it reconnects for a few minutes. The other 75% of the time I am having to power off the printer.

    I don't know if this is related or not, but for some reason the printer name on the web server keeps changing back to "My Duet" with the yellow triangle ! beside it.
    I have "M550 RoMax" set in my config.g

    I am currently running all of the latest firmwares: 1.19.2 for main and server, and 1.19 for web control.

    Help?

    Thanks!


  • administrators

    Thanks for your report. If the name is reverting to My Duet, that could be an important clue as to what is happening.

    Please can you connect via USB as well, then when this next happens, report any reconnect messages that are written to USB. A!so run M122 and report the last WiFi module reset type.



  • Thank you David!

    A few updates from this morning's brief testing attempts.

    I powered on the printer, connected to the web server, and also connected via USB (pronterface on OS X). I homed the towers and just clicked around for a bit before I had to get ready for work. No disconnects. I left it sitting connected and idle as I got ready and came back and checked it about 30 mins later, and no disconnects. Figures, right?

    A few notes:
    -The name on the web server still says "My Duet"
    -When I get the AJAX error and am unable to reconnect, the printer still shows an active connection on my wireless network.
    -One hardware difference: In order to plug in the USB, I have to open the paneling to the base of my Rostock Max v2. Normally I have all of the plexi and melamine panels installed in the base. This essentially encloses the DuetWifi inside of the base. Could it be that the wifi card is receiving too weak of a signal when enclosed? The printer is about 5 feet away from my wireless router in the same room. I am running an Apple Airport Extreme router.

    I will test more tonight, and will reroute the USB cable so that it can be plugged in while the base is also closed.

    Thanks!



  • do you have a cap P right at the start of the name in the M550 line pretty sure it needs it so the command knows it is a name?

    M550 PRoMax



  • Dougal1957,

    I will have to verify when I get home, but I am about 99% sure I do not have the "P" in front.

    Do you think this could cause the random disconnects?

    Thank You



  • don't think so but would explain the name being the default MyDuet on DWC


  • administrators

    The M122 report will also tell you the RSSI (received signal strength) reported by the WiFi module.



  • I noticed that David, and if I remember correctly the RSSI was around -44dBm.



  • Since updating from 1.18 to 1.19.2 this morning I've had frequent communication errors and disconnects. THings had been rock solid on 1.18 for months.

    When it disconnects, I see a Duet Web Control string for the printer name and this error

    Communication Error
    An AJAX error has been reported, so the current session has been terminated.
    Please check if your printer is still on and try to connect again.

    David, let me know if there is any data/testing I can do. I have an identical printer 2' from this one running 1.18 and it has been rock solid all day today so I don't think it's my network.

    Here's the M122 results:

    ENDING:M122
    === Diagnostics ===
    Used output buffers: 1 of 32 (9 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19.2 running on Duet WiFi 1.0
    Board ID: 08DAM-999TL-MQ4S8-6J9F6-3SJ6L-T4BBW
    Static ram used: 21176
    Dynamic ram used: 96200
    Recycled dynamic ram: 1408
    Stack ram used: 4048 current, 7932 maximum
    Never used ram: 4356
    Last reset 03:34:07 ago, cause: reset button or watchdog
    Last software reset reason: User, spinning module GCodes, available RAM 7004 bytes (slot 2)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 28.6, current 33.1, max 35.6
    Supply voltage: min 24.4, current 24.5, max 24.9, under voltage events: 0, over voltage events: 0
    Driver 0: stalled standstill
    Driver 1: stalled standstill
    Driver 2: stalled standstill
    Driver 3: standstill
    Driver 4: standstill
    Date/time: 2017-09-13 15:26:11
    Slowest main loop (seconds): 0.022163; fastest: 0.000000
    === Move ===
    MaxReps: 399, StepErrors: 0, FreeDm: 240, MinFreeDm 234, MaxWait: 3812623ms, Underruns: 0, 0
    Scheduled moves: 56, completed moves: 56
    Bed compensation in use: none
    Bed probe heights: 1.751 1.645 1.587 1.795 1.845
    === Heat ===
    Bed heater = 0, chamber heater = -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19.2
    WiFi MAC address 5c:cf:7f:2b:e6:eb
    WiFi Vcc 3.10, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 39904
    WiFi IP address 192.168.1.230
    WiFi signal strength -84dBm
    Reconnections 0
    HTTP sessions: 1 of 8
    Socket states: 0 0 0 0 0 0 0 0
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)

    regards,
    Michael



  • I don't think the ESP is as sensitive when 1.19x is installed I had similar issues which I solved cos I had a Tl710 lying around which I pressed into service as a AP Point closer to the printer I now get reliable connectiion with an RSSI of approx -72 dBm



  • Hey Michael!
    This is the issue I was telling you I was trying to solve when my G32 went all wonky! Glad, and sorry, to see you in here. Thanks for your diags!

    Dougal1957,
    Sorry, but what is ESP? My router is about 5 feet from my printer, and if I recall correctly my RSSI was -44dBm (ill verify that in a bit).



  • ESP is the WiFi module that is used on the Duet
    I suspect it could overload as well as being to low but i am not an expert in this and I dont know what levels I was seeing before the 710 was put into use



  • Thanks Dougal1957,

    I can easily move the router to test the overload theory, but I highly doubt it will change. But hey, I'm not opposed to trying, as I am certainly no expert! I have noticed a lot more wireless networks around from the neighbors lately, so I probably need to go in and make sure I am on my own channels and such anyways.



  • After an M999 the Duet comes up, via USB an M587 shows the network. M552 S1 just seems to hang but M122 shows connected to access point. But I'm unable to load DWC pages. IP address is correct. M552 S0 then M552 S1 will allow me to reload DWC and connect.

    Seeing WiFi signal strength -79dBm when it can connect and WiFi signal strength -82 to -84 dBm when not. Could it be that sensitive?

    I have a NETGEAR AC1200 WiFi Range Extender arriving tomorrow.



  • It may help to know that I was having the same connectivity issues on 1.18 as I am on 1.19.2. I upgraded to 1.19.2 in an effort to resolve them. I know you said you were rock solid on 1.18, Michael, but I wasn't so maybe that can lend a clue here.

    When you get the disconnects, does the Duet printer in question still show actively connected on your wireless network? Next time this happens I will ping the IP and see if it responds.



  • I am seeing that my Mac - which is in the same room 4' away is showing a good connection with RRSI -62dBm and 145 MBps transmit rate. But the Duet is more shielded in the base of the printer (delta) and closer to a wall so that could explain the signal drop. I'll report back when I have the AC1200 hooked up.



  • My router shows the Duet disconnected. Ping times out.



  • I'll jump in to this thread as well with same issue, I have multiple posts on this same issue in several threads

    https://www.duet3d.com/forum/thread.php?id=2466#p24112

    I "believe" I was not having issues on 1.18, but I only had my duet a week or so before the 1.19 upgrade came out.
    I am also using a Mac as browser device, if that is an issue.

    My signal strength is quite strong:
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19
    WiFi MAC address 5c:cf:7f:a4:a1:64
    WiFi Vcc 3.12, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 39168
    WiFi IP address 192.168.2.53
    WiFi signal strength -35dBm
    HTTP sessions: 2 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)

    This way we can summarize and keep it to one thread



  • Well, I changed the channel for my network to a new channel just as a test, updated the machine name and password, and have been running just off of wifi for about 30 mins now.

    My RSSI is -44dBm

    I was missing the "P" in front of the machine name/pass in my config.g files, so that fixes the issue with the web control always showing "My Duet."

    I haven't been able to print, as my G32 went crazy after the update to 1.19.2

    I will continue to test.



  • I've run with channel as auto, channel 1, channel 6.
    No difference for myself in ability to stay connected.
    I also do have the "P" in front of machine name.

    I've been connected for now 2 days without dropping,, As soon as I print, or sometimes calibrate I drop connection within 20 min, sometimes 2 min.

    Edit:reason I have not lost connection in 2 days is because I've been busy and not done anything with the gui, nt because I've solved the issue.
    I believe this dispels any lack of signal strength reasoning. Signal is strong but for some reason once commands, prints, calibration starts causing the printer to be active the wifi connection drops, as if it can't keep parallel processes going.

    Edit 2: reconnecting to the laptop remotely that has the browser interface running, which ran for 2 days, and now an hour later when I reconnect it has the AJAX error and another disconnect.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.