Bossac command structure



  • Hi
    I don't want to take over another person's thread trying to solve Wifi connections dropping on version 1.19.2 and 1.20.7.

    I am trying to reinstall version 1.18.2

    I erased the board

    Bossac is in a directory called mytemp along with DuetWebControl-1-15a.bin

    I am working from the documentation on http://reprap.org/wiki/Duet_Firmware_Update

    I enter " bossac.exe -e -w -v -b DuetWebControl-1-15a.bin" and get a message "Auto scan for device failed. Try specifying a serial port with the '-p' option.

    I've tried adding -p com5 which then tells me that there is no device connected to com5 (which there is)

    Does DuetWifiFirmware need to be loaded first, or am I using the command incorrectly?



  • With bossac I had a listComPorts.exe command that showed which devices were connected. When I last used it on an erased Duet it just showed up as an arduino. You can also see this in device manager (assuming your using windows)

    The command I use is -
    bossac.exe –port=COM12 -e -w -v -b Firmware.bin

    I long press the ease button first.

    There is also a Bossa GUI you can get where you pick the com port from a drop down. That came from http://www.shumatech.com/web/products/bossa



  • Hi DADIY
    Thanks for your very helpful post. I'm pretty sure that I had not entered the parameters correctly. Should I be installing Firmware.bin at this stage instead of WebControl? I was figuring I had to get the network working first so I would have wifi access.

    Thanks
    Tim



  • Hi DADIY
    My port shows up as COM5 - Escher 3d - USB\lots of characters and if I enter

    bossac.exe –port=COM5 - e -w -v -b duetwififirmware.bin

    it will return that there is

    No device found on COM5



  • Update
    Rebooted my laptop which let windows install updates.
    Bossac (windows version) let me install DuetWifiFirmware.bin



  • Update
    Can't talk to the board with USB anymore. Driver on USB port is not recognizing the board or at least it is corrupting when I connect to it.



  • Found the thread dealing with being unable to connect to the board.

    Install SAM-BA 2.17
    Followed this
    https://duet3d.com/wiki/Updating_main_firmware#Fallback_procedure_.233
    and I now get the error message
    Can't connect at91sam4e8-ek

    Every Document I find to follow to try to recover my board ends up at a dead end with an error message.

    I tried to work through the Bossa instructions when SAM-BA failed and now I am left with
    "The interactive version (Bossa) does not work on high dpi screens, but you can still use the command line version (bossac). If you use the interactive version, you must check boxes Erase all, Lock, and Boot from Flash before pressing Write." from the bottom of the page above.

    Since the windows version won't run without a fatal error on startup, I'm trying to use the CMD window version, and I'm not sure about the duet drivers that I am supposed to install. I install them, and there is nothing new in the listcomports. If I run Bossa, it tells me there is no board.

    Earlier in the day I had a com port show up that said Escher 3d, but that com port failed to find a board too.

    …I have spent a few days now trying to recover to some version that might work, all because I tried to install the IR Probe.

    This board has only ever worked because John Smart was wonderful and spent the better part of a day remote connected to my PC setting up all of the details in the configuration file. Prior to John's help I had no ideal what the difference was between my printer and the printer profile I copied from the configurations that people had added on the main configuration screen. I had to use one of those to convince the firmware that I really didn't have a Delta printer even though everything I had entered on the configuration tool for a "new" configuration was for a cartesian printer. The configuration tool always gave me the macros for the delta.

    It's been 1 step forward and 3 steps back for everything that I have tried to add or change on this board with the exception of the display. That worked perfectly from the moment of install and still works great.

    I really don't want to toss the investment that I have made for the DuetWifi, Display and IR Probe, but I bought the printer to print 3d objects, not to go around in circles trying to find some way to get the software to work.


  • administrators

    When you load Windows Device Manager with the Duet connected via USB, what COM ports show up?



  • That changes. Earlier this morning I was working from my laptop which normally shows Com4 as the USB com port. At one point, I loaded the duet drivers and for a period of time I had Com5 which I have not seen before, and it was stated as Com5 - Escher 3d - USB\and a long series of letters, numbers and & signs here.

    Since I was getting messages from my attempts to connect to the Com4 port earlier saying that there was no board on Com4, I didn't want to mess up my chance on Com5 when it was listed as -Escher-. I put the entire string behind the brossac.exe command and it returned an error for unknown parameters or something along those lines out. After that, Com5 was gone completely. I pwer cycled the board and the laptop and when I plugged the usb back into the laptop I got a message from Windows that it couldn't process the USB connection. There was a specific message of failure indicating that the USB port was receiving invalid information.

    I tried with Pronterface, and then YET and neither would find my com port on the laptop at all.

    Since I could not talk to the board, I moved my connection to my main PC and I originally had COM1 which was an internal USB to Com port. Every attempt to load the Duet.inf file gave a successful completion message, but Pronterface came back with an error when I tried to connect. I don't remember the exact error, but the implication was that it had contacted the board and didn't get the message it was expecting, so it quit. I don't know if that's drivers, or the fact that the only firmware I had been able to install was the WifiFirmware for the board, but not the WifiServer software.

    I never had a run with getting both firmware.bin files on the board. If I installed one, the second one would fail. If I switched the order, the first installed, but again, not the second.

    Since then I have not been able to get back to having the Escher 3d port show up again. It did register only once as COM6 so at that point I had two showing, but I couldn't complete the firmware uploads.

    Hope that helps sort things. I could have a mismatch in Duet.inf and .bin files at this point. I know I saw the .inf file in a couple of different places, so I might have managed to mix the versions.


  • administrators

    It would be helpful to know the error message that Pronterface returned.

    Windows has a bug that causes it to stop recognising a USB port if the device on it changes quickly, which is what happens when a Duet changes from the Bossa port to the Duet port, or when you reboot the Duet. That's what probably happened on your laptop. I run my Duets through a hub, and when this happens I find that unplugging the hub from the PC and plugging it back again solves the problem. Or you can switch to another USB port (the COM port number will change). Or you can reboot the PC.

    The latest duet.inf files work with older firmware versions, so if you make sure it is the latest then it will be OK.

    In the longer term you will need to update to firmware version 1.19.2 or 1.20. I've not heard of anyone else being unable to connect at all using firmware 1.19.2.



  • I will likely have another opportunity to get the exact message from Pronterface. I will certainly add that to this thread.

    I have noticed that windows has it own stuff going on which really makes it hard to repeat things. I have probably done more rebooting on Windows 10 than I every did on Windows 7.

    It's great to know that the latest duet.inf won't cause me grief with other versions. From what I have seen in my reading on the forum, version 1.20.7 seems well received and quite stable. That is my target.

    My greatest need at the moment is knowing how to get the bin files on the board. There are 3 as far as I know and they need to be in the /sys folder. Are they supposed to disappear from that folder once they have been loaded up to the board? Mine do.

    I have had M997 S0:1 work once to upload the board and server bins at the same time, but only once, and it was entered via YET.

    Please clarify, if I can get the USB Com port on the PC to accept the - Escher 3d - labelled version, can I just issue the M997 S0:1 from either Pronterface or YET and does it matter which I use.

    I think I have done more harm than good by using brossac although I did get it to upload each bin file once.

    I am going to get rid of everything I have firmware wise, and download a fresh set of 1.20.7 That way I will know that I'm not cross contaminating my files.

    Thanks for the help! I'm having a real struggle here. Building my drones from scratch was easier than setting up this printer and that just doesn't seem right 🙂



  • Ok, the error message from Windows when connecting is Unknown USB Device (Device Descriptor Request Failed) - Driver Error



  • One step at a time.
    I installed from duet.inf message says successful

    Plug in the USB cable to the board.
    Pause
    No Message on the PC screen
    Device Driver reports "Unknown USB Device (Device Descriptor Request Failed) driver error
    CMD Window listcomports COM1 - (Standard Port Types) - ACPI\PNP5051\0
    Pronterface opens with COM1 proposed.
    Connect …............Connecting...will stay like that forever, no apparent timeout
    Issue a Reset Heat indicators turn to blue (don't know if it's talking to the board. could in Pronterface software.
    Issue M115 G Code Error Printer is not online (never thought it was)
    Close Pronterface

    Open YAT Terminal1 - COM1 - Open - Connected
    Issue M115 G Code ...no response back
    Load DuetWifiFirmware.bin to Send File oops, looks like it thinks it's ascii. Can't upload that way.
    Copy 1.20.7 version of DuetWifiFirmware.bin into /sys folder on memory card
    Issue M997 S0 G Code Echo on monitor, no other activity
    YAT still reporting Serial port Com1 Open and connected.

    I suspect this will sit like this forever.

    So, do I need to use Brossac, or SAM-BA. I have version 2.17 which is what the document said I need to use.

    Please advise next steps to try.
    Thanks,
    Tim


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.