Refresher Needed: 1.17 to 1.19.2



  • Hello,
    Been enjoying the DuetWifi for about a year now and haven't even needed to review my config.g. This thing just runs great. In my attempt to give it a static IP I successfully upgraded from 1.17 to 1.19.2. There is a lot to read in the release notes between then and now and can't seem to find it. Probably a command change but both my X and Y axis don't stop when the end switches are detected. Probably the Z as well. As for the static address I can't seem to get that to fly either. Below is my config and my latest attempt to a static address. Any help would be appreciated.

    ; Prusa i3 config file for dc42 Duet firmware
    
    ; Prologue and  comms section
    M106 P2 S255			; turn LED's off to see a board reset
    M111 S0                         ; Debug off
    M550 PTevo Tarantula		; Machine name (can be anything you like)
    M551 Preprap                    ; Machine password
    M552 P192.168.1.2		; Set IP
    M552 S1				; Enable Wifi
    M555 P2                         ; Set output to look like Marlin
    M575 P1 B57600 S1		; Comms parameters for PanelDue
    
    ; Motor Map
    M584 X0 Y1 Z2 E3
    
    ; Movement section
    M569 P0 S1                          	; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S1                          	; Drive 1 goes forwards
    M569 P2 S1                          	; Drive 2 goes forwards
    M569 P3 S0                 		; Drive 3 goes backwards
    M569 P4 S1                       	; Drive 4 goes forwards
    M574 X1 Y1 S0				; X and Y end stop configuration (at low end, active low)
    M906 X800 Y800 Z800 E1000     		; Set motor currents (mA)
    M201 X1000 Y1000 Z15 E1000     		; Accelerations (mm/s^2)
    M203 X15000 Y15000 Z100 E3600  		; Maximum speeds (mm/min)
    M566 X600 Y600 Z30 E20       		; Minimum speeds mm/minute
    M208 X200 Y280 Z480			; set axis maximum (adjust to suit your machine)
    M208 X0 Y0 Z0 S1			; set axis minimum (adjust to make X=0 and Y=0 the edge of the bed)
    M350 X64 Y64 E64 I1  			; Set 64x microstepping with interpolation
    M92 X320 Y320 Z1600			; Set axis steps/mm
    M92 E388.3496    	            	; Set extruder steps per mm
    G21                   		        ; Work in millimeters
    G90                       	        ; Send absolute coordinates...
    M83                                	; ...but relative extruder moves
    
    ; Z probe section
    M565 X32 Y-10 Z0			; probe offset from the extruder tip to the probe position
    M558 P1 X0 Y0 Z1 H4 F200 T5000		; Mode 4 used for inductive probe, dive height 4mm, probe speed 200mm/min, travel speed 5000mm/min
    G31 X0 Y0 Z2.16 P500        		; Set the probe height and threshold (Glass = Z2.16, Blue Tape = Z3.16) Lately 3.6 Tape
    
    ; Auto Bed Compensation Points (Min:Max)
    M557 X10:160 Y55:205 S150
    
    ; Heater and thermistor section
    M305 P0 R4700 T100000 B3950		; Bed thermistor (P0) is 100K @ room temp
    M305 P1 R4700 T100000 B4388 		; Hotend thermistor (P1)
    M307 H0 A150.7 C512.4 D4.5 B0		; Results from Bed Auto Tune on 1/21/17
    M307 H1 A623.0 C263.3 D7.7 B0		; Results from Extruder 0 Auto Tune on 1/21/17
    ; M301 H1 P10 I0.10 D100 T0.50 S1.0	; PID settings for extruder 0
    M570 S120				; Increase to allow extra heating time if needed
    
    ; Filament Out Switch
    M581 T2 E1 S1 C0			; Filament switch runs Trigger2.g on rising edge for all prints
    
    ; Tool definition section
    M563 P0 D0 H1                   	; Define tool 0 to use extruder drive 0 and heater 1
    G10 P0 S0 R0                    	; Set tool 0 operating and standby temperatures
    
    ; Epilogue
    T0					; select first hot end
    M106 P1 T45 H1				; sets FAN1 output to Hotend to be thermostatically controlled @ 45 deg.
    M106 P2 S255				; turn LED's on
    
    


  • Hi, I don't know how to set a static ip, but my network paramerters are like this:

    M550 PDuetDelta 					; Set machine name
    M552 S1 						; Enable network
    M587 S"YourNetworkSSID" P"YourNetworkPASSWORD" 		; Configure access point and IP addresses.
    M586 P0 S1 						; Enable HTTP
    M586 P1 S0 						; Disable FTP
    M586 P2 S0 						; Disable Telnet
    M575 P1 B57600 S1					; Comms parameters for PanelDue
    

    I can access the printer by its name, in this case it's called DuetDelta, so it connects by just typing http://DuetDelta.local/

    As for the other issue, sorry I wouldn't know.
    You can try by generating a new file using the RRF tool and compare it with the old one. Maybe you can spot something.

    Best of luck.


  • administrators

    On the Duet WiFi you set up a static IP address in the M587 command where you define the router SSID and password.



  • Here are the instruction for David's answer.

    https://duet3d.com/wiki/G-code#M587:_Add_WiFi_host_network_to_remembered_list.2C_or_list_remembered_networks

    Pay close attention to the capitalization of the network name and pass; this will require some added single quotes in your M587 command. Note too that spaces and semicolon characters in the password need special attention.



  • Thanks for all the suggestions but without code that responds to my end stops it's useless. I need to figure that out first unless I need to print which will just mean reverting back to 1.17.



  • @lasakro:

    Thanks for all the suggestions but without code that responds to my end stops it's useless. I need to figure that out first unless I need to print which will just mean reverting back to 1.17.

    Could do with a little more info about how and when the end stops are ignored. From what I can gather, they worked on 1.17 but something is amiss using 1.19? If that's correct then from the release notes we can see that deploy probe and retract probe files need to be deleted from the "sys" directory otherwise they will be acted on. So assuming that you have a probe that does not need to be deployed, and assuming that the behaviour only occurs during homing, then that might be a possible explanation. Otherwise, a bit more info about what is happening will help.



  • also I couldn't see a definition for the Z Endstop in your Config.G file either now it may not be needed depending on type of Z Probe you have so that is also info we need


  • administrators

    End stop detection has not changed between version 1.17 and 1.19. Use the M119 command or the Machine Properties page of DWC to check whether the firmware is reading your endstops correctly. Also look at the endstop LEDs on the Duet. If they turn on when the endstop witches are triggered, your configuration is correct. If they are normally on but turn off when the endstops are triggered, you need S1 instead of S0 in your M574 command. If they don't change when the endstop is triggered, then you have a wiring issue, or incompatible endstop sensors.



  • Have you on of those days where you look back and say "boy was I an idiot"? Tried my printer today and the end stops are working fine. I know I had to rush to the power switch after one of the axis wouldn't stop. Well moving on, sorry about that.

    As for the M587 command I tried it under 4 circumstances and still can't set an IP:

    1. Putting Wifi idle at the Pronterface command line with M552 S0. Sending M587 I192.168.1.2
    2. With Wifi running sending M587 I192.168.1.2
    3. Placed M587 I192.168.1.2 in my config.g before the M552 S1 command.
    4. Placed M587 I192.168.1.2 in my config.g after the M552 S1 command.

    So where is the correct location for this and what am I missing? The SSID and DHCP are working fine. I'm just tired of having to guess which address got leased out.

    Edit: I removed the old M552 I192.168.1.2 from my config.g before trying the above.


  • administrators

    With M587 you have to give the IP address at the same time as you give the SSID and password, because the IP address is specific to when you connect to that SSID.



  • I put the Wifi idle. Needed to delete my current SSID with M588. Sent SSID, PW and IP this time and it worked. Thanks for your help.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.