New Wifi install problems, need help



  • I am converting a Black Widow to Duet and have gotten the WiFi connection all functioning. However, I cannot get the drivers to work properly. I don't know if it is a function of my installation, broken board or incorrect config. Here are two photos of wiring, powered and the config.g. I appreciate your help!

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active high endstops

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M558 P0
    M566 X600 Y600 Z30 E20 ; Set maximum instantaneous speed changes (mm/min)
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X360 Y250 Z350 S0 ; Set axis maxima
    M92 X80 Y80 Z4000 E2750 ; Set steps per mm
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z15 E1000 ; Set accelerations (mm/s^2)
    M906 X800 Y1000 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 Black Widow ; Set machine name
    M552 S1 ; Enable network
    586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    Sorry, don't know how to display images....



  • Do you mean that the steppers are turning the wrong direction or rotation? or just not working at all



  • When I try to activate say, X stepper, it "dithers". For Y, X "dithers". For Z, X dithers and then moves 10mm in the wrong direction. End stops are mechanical and work n each correct circuit.



  • Have you check that you have the stepper motor wire connected correctly? in the correct coil pairs


  • administrators

    Do the stepper motors vibrate loudly when you try to move them? If so, that usually means you haven't paired the wires correctly.



  • The stepper motor wire colors are red, blue, green black at the board and red green blue black at the steppers - the former board was wired according to the stepper order. I have tried reversing the green and blue but didn't get anywhere with that. And tried reversing the entire order at the board, but that didn't help either. I suspect a piece of knowledge is there that I am missing.


  • administrators

    @1d1:

    When I try to activate say, X stepper, it "dithers". For Y, X "dithers". For Z, X dithers and then moves 10mm in the wrong direction. End stops are mechanical and work n each correct circuit.

    Do you mean that whichever motor you try to move, the only motor that moves at all is X?

    I didn't spot anything wrong with your config.g file. Is that definitely the one that is running on your Duet - the one you can see if you go into Settings -> System Editor in the web interface, and select config.g to edit?

    Which firmware version are you running? Look in Settings -> General in the web interface to find out.



  • Yes, to the current config. I have gotten some movement of Y and Z in the course of trying to get things working. Also determined the correct extruder direction because the heater controls work, the fan works and E stepper worked at least that time - I haven't tried it again since having the other motion problems. V 1.19, brand new board from Filastruder.
    If I switch X and Z at the board, all three steppers come on briefly without movement, just the vibrating. I have also tried different mA settings from 1200 down to 800 without success.



  • Watch the video and check you wiring on the steppers https://www.youtube.com/watch?v=S0pGKgos498



  • Just throwing this out in hopes that it might move you in the right direction and since I'm a total newb take it for what its worth.. but "All" of my movement issues were related to the end stops not working correctly and or being wired up wrong.

    On the configuration page you can view the functionality just make sure that they are working in either the open or closed state. Closed for me means the red lights are on on the board, when the limit is tripped the light goes off.

    VB,



  • OK, so my wiring was off on one pair and now all axes show some movement. However, despite the board showing correct end stop wiring, the X end stop doesn't stop the X driver. All three stepper commands result in X movement and not proper movement on the others. The X end stop triggers properly. Y and Z end stops seem to work correctly but neither axis moves as t should with the X always getting involved.
    Thank you, Tim Willy, David and VB. Closer but no success. Yet…


  • administrators

    Please can you send M669 without parameters, also M584 without parameters, and let me know what the responses are.



  • M669
    Error: M669 parameters do not apply to Cartesian kinematics

    M584
    Driver assignments: X0 Y1 Z2 E3:4:5:6:7:8:9:10:11



  • Did you follow this for connecting and setting up your endstops? https://duet3d.com/wiki/Connecting_endstop_switches



  • Yes. Active high, endstops correspond to correct axes, leds on, then off when triggered. Mechanical switches.



  • This is a long shot.

    I know that M584 without any parameters seems to be reporting the correct drive mapping (apart from the fact that non existent drives 4 to 11 are mapped to non existent extruders but that shouldn't matter). However, there is no M584 command in your config.g therefore the values that are reported must be the default settings. Normally M584 would go before the other axis parameters like steps per mm, speeds accelerations etc). So maybe, (just maybe), the absence of the command is what is throwing things.

    So try putting this near the top of your config.g file (as the first line after "Drives").

    M584 X0 Y1 Z2 E3. This will force the drive mapping to occur before steps per mm etc are assigned.

    Like I said, it's long shot but…....



  • Tried it, no help. Here's the sequence:

    Home X; X carriage moves to end stop, triggers the end switch but doesn't stop, then returns about 3/4 length back
    Home Y; X carriage moves to end stop, returns to center bed, Y carriage moves 10 mm, everything stops.
    Home Z; X carriage moves to end stop, returns halfway, Z raises about 30 mm, everything stops.

    E works as it should



  • Have you tried making a new config with the online configurator ? https://configurator.reprapfirmware.org/



  • Yes, I've done that three times, tried someone else's and put this one together myself.


  • administrators

    I think you may have your motor wiring swapped, in particular I think you may have the X motor connected to the Z motor connector. Please check. The order of the motor connectors is ZA/ZB, Y, X, E0, E1 which may not be what you were expecting.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.