Cant get my duetwifi to work after new FW.



  • Now I would need some help here before losing my mind.

    Has updated my duetwifi to the latest fw "Duetwifi fw - Duetwifi server" as well as has latest DWC.

    At startup, there is no network in spite of the correct wifi and password, and error no2 is when I'm going to make a G29 so stay hotend about 7-10cm above the heating bed.

    I have tried to change everything but will not work.

    I would be extremely grateful if I can get some tips on what I'm doing too wrong so I can make everything work.

    I'm totally new to the duetwifi card unfortunately and have it in one Kossel printer.

    Thanks in advance πŸ™‚



  • Welcome to the forum.

    Can you provide some more details?

    Which firmware did you update from?
    What is the exact version of all 3 firmwares you updated to?
    Can you connect via USB to issue commands?
    anything else?

    Thanks!



  • Thanks πŸ™‚

    It was 1.19 Before upgrade.

    New FW is :
    DuetWiFiFirmware-1.20RC4
    DuetWiFiServer-1.20RC1
    DuetWebControl-1.20-RC3

    Downloaded all firmware from https://github.com/dc42/RepRapFirmware/tree/dev/Release/Duet-WiFi/Edge
    Yes i can connect to board thru Pronterface with no trubbel at all.


  • administrators

    If you send M552 S1 from Pronterface, what responses do you get within the next minute? If you don't get a message saying that the connection to your router succeeded or failed, send M552 with no parameters so see what state the module is in.



  • @dc42:

    If you send M552 S1 from Pronterface, what responses do you get within the next minute? If you don't get a message saying that the connection to your router succeeded or failed, send M552 with no parameters so see what state the module is in.

    I get this.

    SENDING:M552 S1
    WiFi reported error: no known networks found
    Wifi module is idle

    SENDING:M552
    WiFi module is idle



  • can you send a M587 and report that back?



  • @Dougal1957:

    can you send a M587 and report that back?

    SENDING:M587
    Remembered networks:
    GixxerTurbo IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0



  • ok so it has remembered your Network thenI have seen david say in another thread that sometimes happens due to the new stack and it normally resolves itself after a few reboots (3 or 4 I think he mentioned) worth trying and I am sure he will be along soon to advise.

    https://www.duet3d.com/forum/thread.php?id=3387&p=3 towards if not the very bottom of that page


  • administrators

    @Crille:

    @dc42:

    If you send M552 S1 from Pronterface, what responses do you get within the next minute? If you don't get a message saying that the connection to your router succeeded or failed, send M552 with no parameters so see what state the module is in.

    I get this.

    SENDING:M552 S1
    WiFi reported error: no known networks found
    Wifi module is idle

    SENDING:M552
    WiFi module is idle

    Are you certain that your WiFi network SSID is called exactly GixxerTurbo ? SSIDs are case-sensitive.



  • @dc42:

    @Crille:

    @dc42:

    If you send M552 S1 from Pronterface, what responses do you get within the next minute? If you don't get a message saying that the connection to your router succeeded or failed, send M552 with no parameters so see what state the module is in.

    I get this.

    SENDING:M552 S1
    WiFi reported error: no known networks found
    Wifi module is idle

    SENDING:M552
    WiFi module is idle

    Are you certain that your WiFi network SSID is called exactly GixxerTurbo ? SSIDs are case-sensitive.

    Yes im 100% sure that my SSID is this πŸ™‚


  • administrators

    Strange, it's saying it can't find that network. Have you hidden the SSID on your router? Or could it be a signal strength problem?



  • @dc42:

    Strange, it's saying it can't find that network. Have you hidden the SSID on your router? Or could it be a signal strength problem?

    No i have not hide my network and signal strength is almost 100%, i have router in same room as printer.



  • Can I ask a silly Question what is the Router make and Model my Wifi since v1.18 will not connect to my Netgear D6400 for more than a few seconds but it works fine with my TP-Linl TL710 or whatever model it is when configured as a wifi extender.



  • I have ASUS RT-AC88U and it works great on all other stuff but not on Duetwifi 😞
    Its realy strange that it dont work.

    Is it possible to reverse the duetwifi to factory state that it was shipped?…



  • it should work mine does see the router but then boss out which is different to your symptoms I would do M588 to forget all networks and set that bit up again. M588 * to forget all remember when setting it back up again you can't do it with the Paneldue or pronterface as neither of them can pass lowercase characters and as DC42 has said it is case sensitive.



  • Ok i try again and set it up in YAT and see if its differense. Have done this several times and still no go 😞



  • No it will not work..

    Printer is now online.

    m587
    SENDING:M587
    Remembered networks:
    GixxerTurbo IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0


  • administrators

    Does M552 S1 still report "no known networks found" ?



  • @dc42:

    Does M552 S1 still report "no known networks found" ?

    Yes it does… Is it possible to reverse to older FW this is no fun..
    Brand new duetwifi that dont work 😞



  • Have you configured your router to be compatible with legacy radio modes? Your router is an AC router, and possibly is not configured to work with the the G (or N?) standard that the wifi uses.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.