Won't connect to Wifi (but it used too…)


  • administrators

    It does sound as though the wifi module may have developed a fault, or else you have hit an obscure bug i the wifi firmware. The two courses of action I can think of are:



  • @torge:

    Hallo,
    if have similar Problems with my duetwifi. After 4 month of usage the duetwifi lost the wifi connection from time to time. Now the wifi seems to run but the machine is not able to connect. If i ping the machine only the first ping works.
    This look like this.

    ping duetwifi
    PING duetwifi.fritz.box (10.10.10.41) 56(84) bytes of data.
    64 bytes from DeltaDrucker.fritz.box (10.10.10.41): icmp_seq=1 ttl=128 time=7.58 ms

    –- duetwifi.fritz.box ping statistics ---
    13 packets transmitted, 1 received, 92% packet loss, time 12002ms
    rtt min/avg/max/mdev = 7.588/7.588/7.588/0.000 ms

    Connection via Pronterface work.

    SENDING:M552 S1
    WiFi server starting up
    DuetWiFiServer version 1.03 (ch fork)
    Flash size 4194304, free RAM 32840 bytes, WiFi Vcc 3.08V, host name: duetwifi, reset reason: Turned on by main processor
    WiFi server connected to access point SweetHome, IP=10.10.10.41, signal strength=-66dBm

    Whats on with the wifi interface? I think it is an electronic failure, I am right?

    I got the same weird problem. I used DUET wifi 1 month back. After that I used the 3d printer today only. Initially the DUET Wifi was not connecting. I found this thread and thought the Wifi module is not working. I moved my printer closer to the router and used pronterface. I reset the wifi by M551 S0 and again used M551 S1 and found the signal strength=-48dBm.

    It gave the IP of 192.168.0.5, but nowhere I was able to connect to this IP.

    One of my PC's was connected to the router through ethernet cable. From that PC, I used Chrome browser and typed 192.168.0.5, and voila.. It worked. I am surprised by the behaviour of DUET Wifi. Eventhough the Wifi board is very good, like others we are also facing too much problems. Next we should go only to the Duet Ethernet.



  • I solved "my" Problem!
    After I almost went mad, I restart my Fritzbox 7390 (in Germany a very popular Wifi router) the first time after 3 months. I can not believe it but the DuetWifi-Board is now easily accessible again. Can it be that the Wifi router masked the DuetWifi board as unsafe?



  • I solved "my" Problem!
    After I almost went mad, I restart my Fritzbox 7390 (in Germany a very popular Wifi router) the first time after 3 months. I can not believe it but the DuetWifi-Board is now easily accessible again. Can it be that the Wifi router masked the DuetWifi board as unsafe?


  • administrators

    There was a case recently of a router apparently blocking the MAC address of a wired Ethernet connection. So this does happen. My best guess is that if you get an IP address conflict, the router blocks one of the two Mac addresses involved.


  • administrators

    There was a case recently of a router apparently blocking the MAC address of a wired Ethernet connection. So this does happen. My best guess is that if you get an IP address conflict, the router blocks one of the two Mac addresses involved.



  • I use fixed IP addresses for all devices on my router. But after rebooting the router i see a new firmware on it. Maybe the automatic installation of the router does not work reliably. A hardware reset seem from time to time not to harm, please excuse the stupid error.


  • administrators

    It's not a stupid error, IMO we have every right to expect routers to just work.



  • Hi guys,

    have a similar problem with my new DuetWifi board.
    Connects fine when powered up and is accessible. After a few minutes - e.g. 40 min into a print - it can not be pinged anymore or accessed through the webpage. Restarting the machine brings it back immediately.
    When I enter M551 S0 on the PanelDue Console I get Wifi Server disabled, when I enter M551 S1 however I do not get any readout on the console. Not sure if that is normal or not (for the Panel).

    Once additional point: I used the accesspoint method to get it connected and left the network settings in the reprap configurator empty (only entered the machine name). Could that be the issue?

    Help is very much appreciated.

    Thanks,
    Eric



  • Hi guys,

    have a similar problem with my new DuetWifi board.
    Connects fine when powered up and is accessible. After a few minutes - e.g. 40 min into a print - it can not be pinged anymore or accessed through the webpage. Restarting the machine brings it back immediately.
    When I enter M551 S0 on the PanelDue Console I get Wifi Server disabled, when I enter M551 S1 however I do not get any readout on the console. Not sure if that is normal or not (for the Panel).

    Once additional point: I used the accesspoint method to get it connected and left the network settings in the reprap configurator empty (only entered the machine name). Could that be the issue?

    Help is very much appreciated.

    Thanks,
    Eric


  • administrators

    It's M552 you need to use, not M551.



  • Thanks. To update, my issues went away after I updated the router. Happily pushing stuff over to the duetwifi now 😉


Log in to reply