New PanelDue 1.20beta1 firmware available



  • Thank you for fixing the extrusion factor bug! I'll get mine updated next week and post if I have any problems.



  • What's the difference between PanelDue-v3-7.0.bin and PanelDue-v3-7.0E.bin? I've got a v3 PanelDue and a 7" LCD but not sure about the 'E'.



  • I have 3) V1.1 PanelDue boards running 1.16 with 7" screens. What version firmware to update to? Can I update from the DWC yet?


  • administrators

    @DaveA, don't use the 7.0E version, it's for a different type of display that isn't shipping yet.

    @joestefano, if you have upgraded your Duets to main firmware 1.20 then I suggest you upgrade the PanelDues to 1.20RC1. Otherwise use PanelDueFirmware version 1.17.

    @kazolar, please explain the symptoms of the "power glitches".



  • Installed and working. Any chance we could have the virtual heaters like mcu and on my setup I have chamber and heatsink defined which show in the extras section on DWC?



  • David, there is no "PanelDues to 1.20RC1" as you indicate above.

    I have 3) V1.1 PanelDue boards running 1.16 with 7" screens. I am running 1.20.1RC1 Firmware on my DuetWiFi.

    1. What version firmware for the PanelDue do I update to v2 or v3?
    2. Can I update the PanelDue firmware from the DWC yet?

  • administrators

    1. Use PanelDue-v2-7.0.bin. The v2 binaries work on v1 and v1.1 boards too.

    2. No. It will eventually be possible, but only for PanelDue v3 control boards.



  • Any other advantages to the v3 board over the v1.1?


  • administrators

    • It's faster, which makes the redrawing a bit snappier
    • It can be connected to a generation 2 Duet revision 1.01 or later using just a 10-way ribbon cable, which is easier to make than the 4-way cable - but then the cable length is more limited
    • It has more flash memory and RAM, but we're not making use of that yet, except to allow OEMs to have a custom splash screen.

    IMO it's not worth upgrading an older PanelDue at present, but that may eventually change if we find that we can't fit new features into the memory of the older versions.



  • Thank you. Happy New Year!!!!!



  • Thank you David for this Beta! I've found an issue with the dialogs. Dialogs without an OK or Cancel button (S0) don't dissapear when the next dialog sould be displayed.
    In the example below the "Wait while bed is heating up to 60C" Message stays until the last S2 Dialog in the last line appears.

    G28 ; home all
    G0 F6000 X0 Y0 Z250 ; lower the effektor
    M291 P"Mount z-probe" R"Autocalibration" S3 T0 ; Display message
    M291 P"Wait while bed is heating up to 60C" R"Autocalibration" S0 T0 ; Display message
    M140 S60 ; heat bed
    M116 ; wait for the temperatures to be reached
    M291 P"Calibration 1/2" S0 T0 ; Display new message
    G32
    M291 P"Calibration 2/2" S0 T0 ; Display new message
    G32
    M500 ; save calibration
    M140 S0 ; bed heater off
    M291 P"Calibration complete" S0 T0 ; Display new message
    M291 P"Dismount z-probe" R"Autocalibration" S2 T0 ; Display message

    Also an M292 does not help.



  • Addendum, it works if the macro is started from the dwc, maybe it helps with the debugging.


  • administrators

    Thanks, I'll take a look. I have noticed a related issue. If a M291 S2 dialog is used then it appears on both DWC and PanelDue as it should; but if you acknowledge it from DWC, it remains on PanelDue.



  • I installed this firmware. Glad it fixed the extrusion factor bug. It is working for me but I don't use any dialogues so I cannot comment on that.



  • I may have spoken too soon about the extruder % adjustment being fixed. While it is not assigning it to T0 all the time like it previously was, it is not just not changing any of them it seems. I've tried adjusting T3 and it always goes back to 100. I can adjust it properly from DWC though.

    I'm using a Panel Due V2 with 7 inch display.



  • I am noticing the same issue, I tried adjusting the extrusion % using the Panel Due V2 7", and it is assigning the value to the next extruder, which is rather annoying. I have 4 extruders defined, and I was trying to adjust the extrusion ration – up 10% on T0, and it set it on T1 -- there was no way to adjust it on T0 without using the DWC.


  • administrators

    I'll test this again before I release the next beta.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.