Upgrading from 1.18 to latest version



  • Hi,

    I have tried to find the answer to this probably easy question however it doesn't seem to be answered anywhere: Can I upgrade from 1.18 to latest version without going through 1.19? I know that the upgrade procedure is different for 1.19 but can I use the same procedure and go to 1.21 directly?

    Thanks



  • Nervermind, found it. It seems you can…..



  • But I have so many newer problems now…..

    Tried to follow the upgrade procedure. Copied the required files exactly where they have to be copied also checked for the names. I used my PanelDue to give the M997 S0:1 command but it told me it couldn't find the DuetWiFiFirmware.bin. I connected it to Repetier using a USB cable. While I could connect to Duet3D, I couldn't read from the USB card. Then I've found out that there is the option to mount the SD card on Repetier, so when I did that, I could access the contents. I was happy, so I wrote the M997 S0 command, but forgot to add the :1 part, because I was on the wrong update page (from 1.19 to 1.20). After the update I also used the M997 S1 command. However I can't access Duet3D now. Also, the hotend temperature reads as 0 degrees, while the bed temperature reads 2000 degrees. I tried to retry the entire procedure, however now I can't access the SD card anymore, even though I try to mount it, it doesn't mount. Something is awfully wrong here. How am I going to recover from here?



  • Some more information…..

    I edited config.g to add a ; before the M552 command. This time I have been able to access the SD card using the mount option on Repetier. I followed the upgrade procedure again, this time using M997 S0:1 command and it worked. I used the WiFi macro and cınnected to the WiFi network. Then edited config.g to remove the "," in front of the M552. Now I have 2 problems:

    1. The WiFi module is deactivated if I turn off the printer. I have to run the WiFi macro, followed by M587 and M552 S1 to run the WiFi module again each time to connect to the network. It shouldn't behave like this, as I have removed the ; from config.g
    2. My BLTouch stopped its function. It gets triggered when it touches the bed but it doesn't stop the descent of the hotend, so it crashes into the bed if I don't turn the machine off.


  • Sorted the connection problem: It seems that my old config.g file had a P address after M552, so removing that address solved the connection problem. Now, let's find a solution for BLTouch…...



  • It seems that other people also have some problems with BLTouch on the new firmwares. When I home the Z axis, BLTouch is triggered when it touches something (I used a small card to trigger it) but immediately redeploys. This isn't how it behaved before (it should only retract the pin, not redeploy it). Could this be a bug?



  • On the firmware page in Github, there is a changed behaviour report as follows:

    XYZ options have been removed from the M558 command. Use the new M574 S2 option instead.

    Could this be the reason why BLTouch is not acting as it should?

    The endstops portion of my config.g is as follows:

    ; Endstops
    M574 X1 Y1 Z0 S0 ; Define active low and unused microswitches
    M574 S1 ; Define active high microswitches
    M558 P5 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 X-30 Y0 Z1.86 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:175 S25 ; Define mesh grid

    So should I remove the XYZ parts from M558 command and add a M574 Z1 S2 command?

    I also find the explanation of M574 and M558 to be confusing on the wiki page….



  • I made the following changes:

    ; Endstops
    M574 X1 Y1 S0 ; Define active low and unused microswitches
    M574 S1 ; Define active high microswitches
    M574 Z0 S2
    M558 P5 H5 F100 T2000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 X-30 Y0 Z1.86 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:175 S25 ; Define mesh grid

    It seems to be working now. I am testing it.


  • administrators

    If the homez.g file and the Z homing part of homeall.g use a G30 command to to Z homing (which is the usually way when using a Z probe), then you don't need to set up a Z endstop at all.



  • Here's the actual homez.g :

    ; Lift Z relatively to current position
    G91
    G1 Z5 F4800
    G90
    G1 X140 Y90 F3000 ; Go to safe loaction
    M98 Pdeployprobe.g ;deploy the probe
    G91

    ; Move Z down until the switch triggers
    G1 Z-205 S1 F1800
    M98 Pretractprobe.g ;retract the probe after triggering.

    ; Back to absolute positioning
    G90

    ; Tell the firmware where we are
    G92 Z1.5

    So, what you suggest is to use G30 instead of G1 Z-205 S1 F1800?


  • administrators



  • Thanks for the info. If I make this change in homez.g and homeall.g, then I need to change my Endstops section in config.g as follows?:

    ; Endstops
    M574 X1 Y1 S0 ; Define active low and unused microswitches
    M558 P5 H5 F100 T2000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 X-30 Y0 Z1.86 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:175 S25 ; Define mesh grid

    (Removed M574 S1 ; Define active high microswitches (as it is already empty) and M574 Z0 S2)


  • administrators

    If you use G30 to do Z homing then Z0 in M574 is technically correct, although it doesn't actually matter.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.