Duet wiki stuck at 1.21RC2



  • Hi,

    I haven't been able to upgrade to 1.21RC3 and 1.21RC4.
    I've uploaded Duet2CombinedFirmware.bin through the web interface, I copied it to /sys and tried M997
    At first I renamed it to DuetWiFiFirmware and tried both methods.
    still it reports 1.21RC2

    it there anything I can do to debug and solve this issue ?
    file size on sdcard is 379064 bytes
    iap4e.bin is the latest one.



  • Is yours a duet wifi, duet ethernet, or older duet?

    When you run M997, what is shown in the console log in DWC? Often times it will complain that a file name is incorrect (if that is the case.) Does it appear to be going through the firmware update progress?



  • Hi,

    Thanks for your answer.
    as the title says, it's a duet wifi 🙂

    I've just tried again, it looks like the duet reboots as soon as I enter M997 on the usb serial console.
    now I get "Error: G-Code buffer 'serial' length overflow" when I connect again.
    And I'm using screen to connect to it, I'm not sendind any command to the serial port.

    When I do M997 S1, I see some messages

    [[language]]
    Trying to connect at 230400 baud:  success
                                 Erasing 4096 bytes...
                                                      Erasing 233472 bytes...
                                                                             Uploading file...
              5% complete
    
    ```and so on…
    
    when I do M997 S0 the board resets, the usb serial port is closed and I can't see any debug message.
    
    I guess, I'm going to connect to the esp serial port or the the panel due one to see if I can retrieve more info.
    
    anything else I could do ?

  • administrators

    @lolorc:

    when I do M997 S0 the board resets, the usb serial port is closed and I can't see any debug message.

    That is normal. If you have a PanelDue, you can see progress messages on it. If you don't, you just have to wait until the update completes and the serial port becomes available again. It normally takes less than 30 seconds. The Diag LED usually blinks when it completes.

    If you are currently running RC2 then the file needs to be renamed to DuetWiFiFirmware.bin on the SD card. Check that there isn't already an older file with that name.



  • I'll try to connect to one of the real serial port then.
    Because as I said in other post I've tried every combination with the filename.
    When I do M997 it takes less than 30s to restart, it looks like the card simply reboots, so I guess there's a error message sent on the serial port I need to catch and report to you.


  • administrators

    It's normal for a main firmware update to take less than 30 seconds. So my guess is that you already have an RC2 version of DuetWiFiFirmware.bin file on the SD card and it is re-installing that. I suggest you move the SD card to a PC and see exactly what you have in /sys.

    If you can capture the messages from the PanelDue port that that would confirm what is happening. Caution, the signal levels on that port are 3.3V, so you will need a 3.3V serial to USB converter to capture that data.



  • apart from connecting to the due port, that's all that I did.
    Do know why, but I did exactly the same with 1.21, copied server, firmware and iap4e to sdcard, checked the size and did the M997 S1 then M997 S0. it worked;
    it's probably my printer being cheeky with me because I'm not spending enough time with it… 🙂
    panel due serial port still wired, i'll make sure I'll log everything in the future.

    Thanks !


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.