Upgrade duetethernet to current from 1.19alpha3



  • I am trying to upgrade this (I think it's the version that was shipped to me when I bought it) and went in via the web UI following the procedure. It all looks to go as expected, uploads the file, asks if I want to upgrade firmware and then a progress bar which looks to complete. I then disconnects the web interface and I can't get back into it until I reboot at which point discover it's not burned the new firmware to the board. I also have a paneldue on this and get the firmware updating message which never seems to go away until reboot.

    I've also tried the M997 S0 from both the web interface and the paneldue with the same results.

    Basically it doesn't seem to be programming the board even though I can see the file in the sys directory.

    I've tried the 1.19.2 and 1.20 version with similar results.

    Any hints on a way forward would be appreciated.

    Mike




  • administrators

    When you send M997 from PanelDue, what messages do you get on PanelDue during the upgrade process?



  • When I send the M997 I get a dialog box on the paneldue saying Updating main firmware. there is a red X in the top right corner of that box that can be selected but it never goes away or seems to attempts a reboot to the new firmware. If I press the red X, the dialog goes away but the firmware is obviously locked up since issuing any other commands on the paneldue doesn't yield any output.

    As far as the instructions go, I'm assuming that since this is the ethernet version that the filename DuetWifiFirmware.bin should be replaced with DuetEthernetFirmware.bin. Other than that I followed this procedure and have tried method 1 and 2.


  • administrators

    Try uploading iap4e.bin to the Duet first.



  • I uploaded the lap4e.bin to replace the version that was on it although the file size was the same (hard to tell since it's just listed in KB rather than in bytes).

    Went through the upload to 1.19.2 again and same result.

    Here are the versions on it now:

    Firmware Name: RepRapFirmware for Duet Ethernet
    Firmware Electronics: Duet Ethernet 1.0
    Firmware Version: 1.19alpha3 (2017-05-09)
    Web Interface Version: 1.19.3

    The sys directory has these contents:

    File Name Size Last modified
    bed.g 5.7 KiB 6/13/2017, 4:00:12 PM
    config-override.g 586 B 9/20/2017, 9:05:08 PM
    config.g 4.7 KiB 6/18/2017, 12:00:03 PM
    deployprobe.g 289 B 5/12/2017, 4:40:29 PM
    DuetEthernetFirmware.bin 319.1 KiB 3/15/2018, 9:22:12 AM
    DuetWebControl.bin 3.0 MiB 4/7/2017, 1:24:14 PM
    DuetWiFiServer.bin 284.0 KiB 4/7/2017, 1:24:14 PM
    heightmap.csv 833 B 6/14/2017, 10:30:21 AM
    homedelta.g 557 B 6/4/2017, 6:51:22 PM
    iap.bin 51.3 KiB 4/7/2017, 1:24:14 PM
    iap4e.bin 60.0 KiB 3/15/2018, 9:22:07 AM
    pause.g 224 B 5/17/2017, 2:29:18 PM
    resume.g 176 B 5/17/2017, 2:30:00 PM
    retractprobe.g


  • administrators

    I can't remember whether the alpha firmware release you are currently running has any particular upgrade issues.

    What should happen is that when you send M997, the PanelDue should show a series of messages. I think the first is the "Updating main firmware" message, and the second is "IAP started" (it may flash by quite quickly). If you are not getting as far as "IAP started" then the implication is that the main firmware has failed to load and run iap4e.bin.

    You could try upgrading via USB. See https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Fallback_procedure_Num_3. If you press the Erase button followed by the Reset button then the Bossa port should appear.



  • Good news, went through the erase and upload technique and am now on current code. Apparently for some reason things got locked up and wouldn't do the upgrade with that alpha version of code. All good now. I did go through the levels of updates one at a time just to verify that the system is working as expected. Went to 1.19.2, then to 1.20 and finally to 1.21RC4 all without any further trouble.

    just an addition to this but it was completely worth the bit of pain working through this, the new code is substantially more user friendly and several items i'd been fussing with are resolved now.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.