Help please



  • I have spent a week trying to get this setup. I am beyond frustrated. To me it was easier when I flashed the stock board but this has been a headache. I have a Tronxy X5s with the duet wifi. I do not have a z probe. I did the firmware updates so I am on

     RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: 	Duet WiFi 1.02 or later
    Firmware Version: 	1.21RC5 (2018-03-16 build 1)
    WiFi Server Version: 	1.20
    Web Interface Version: 	1.21-RC4
    
    ```Here is my config according to RRF Config, I know I have tweaking to do but I can't even get it to home so I can do anything.
    

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 16 2018 17:56:39 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PCrimReaper ; Set machine name
    M552 S1 ; Enable network
    M587 S"2D6 2.4" P"drakkar#99" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z4000 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S5 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X320 Y320 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P0 H35 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:305 Y15:305 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P1 D0 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T1 ; Select first tool



  • What are you trying to do? What issue are you having?



  • It will not home properly so I can print



  • Here is the homeall code also

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 16 2018 20:00:07 GMT-0400 (Eastern Daylight Time)
    G91                    ; relative positioning
    G1 Z5 F6000 S2         ; lift Z relative to current position
    G1 S1 X-320 Y320 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-320            ; home X axis
    G1 S1 Y320; home Y axis
    G1 X5 Y-5 F6000        ; go back a few mm
    G1 S1 X-320 F360       ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y320; then move slowly to Y axis endstop
    G90                    ; absolute positioning
    G1 X15 Y15 F6000       ; go to first bed probe point and home Z
    G30                    ; home Z by probing the bed
    ;G1 Z5 F100 S2         ; uncomment this line to lift the nozzle after homing
    
    


  • A good place to start would be making sure your endstops are set up correctly, if you connect with a web browser go to the settings tab and machine properties, check the if the endstop is hit. When the endstop is pressed by hand it should change from no to yes and back again as you let go.



  • Wasn't aware I could even do that HAHA! I have literally sat here all day trying and waiting for some help. Thanks for answering!



  • the endstops all say yes automatically. when I press them they say no. It does not matter if i set them to active high or low and the option for end stop location is greyed out



  • This may help:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_Set_endstop_configuration

    Also this:
    https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches

    Im not sure what you mean by "endstop location is greyed out" where are you seeing that?



  • That part is in the RRF Config tool.



  • I dropped back down to firmware 120 and now they are showing the endstops correct



  • Still no luck… banging head in to the wall



  • On my bot changing this line in config.g
    M574 X1 Y1 Z1 S0
    to
    M574 X1 Y1 Z1 S1

    Will cause my endstops to always be triggered until i press them. So it changing that will reverse the behavior, we know your endstops are wired correctly because pressing them on your bot will change the state, its just backwards.

    You have M574 X1 Y2 Z1 S0 in your config so change it too M574 X1 Y2 Z1 S1.



  • Thanks for the help. It was doing something weird. When I would change the switches or direction of a motor it was doing opposite of what I expected. I swapped the x and y motors on the board and boom it worked correct…. Not sure why I had to swamp them tho... I am just happy to have it up after a week of fight lol


  • administrators

    Firmware 1,20RC5 reports the endstop states incorrectly in DWC Machine Properties if they are set to active low. M119 reports them correctly.



  • HI i have also had the same problem where the endstop locations are grayed out in the web config tool. I am using the duet3d wifi board with the firmware 1.21. Initially i had to change the directions of the steppers so that they would home correctly, but that created another problem of having the steppers driving the wrong way. The M574 command only tells it whether the endstop is at the high end or low end of the axis not what direction to drive to look for the endstop.
    I then found the code for the homing ie the homex.g, homey.g, ect... and changed the direction that it drove to find the endpoint.

    Original
    G1 S1 Y1205 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y-5 F6000 ; go back a few mm
    G1 S1 Y1205 F360 ; move slowly to Y axis endstop once more (second

    Modified
    G1 S1 Y-1205 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-1205 F360 ; move slowly to Y axis endstop once more (second pass)

    after all that is there a reason the grayed out area is disabled?????


  • administrators

    I think I've found a bug in the configurator. If you set the machine type to Delta, then the endstop locations are grayed out and disabled - which is sensible because the endstops are always at the high end. But if you then change the machine type back to Cartesian or CoreXY, it doesn't enable them again. I will get this fixed.



  • Thats great works now. Thanks


  • administrators

    @flippnswitchez On a CoreXY swapping the motors reverses an axis. There are 8 combinations:

    Motor 1 Motor 2
    X Motor forward Y Motor forward
    X Motor forward Y Motor backward
    X Motor backward Y Motor forward
    X Motor backward Y Motor backward
    Y Motor forward X Motor forward
    Y Motor forward X Motor backward
    Y Motor backward X Motor forward
    Y Motor backward X Motor backward

    One of these combinations will always result in a left handed cartesian system. The other combinations will result in either a right handed cartesian system, reversed axises, or swapped axises. The exact setup you need depends on your motor location, wiring, and possibly belt routing.

    For reference you ultimately want a left handed cartesian system. This is important because a right handed system will print things backwards, this isn't a problem 90% of time but is maddening 10% of the time. The correct cartesian co-ordinate system looks like this:

    0_1523851005936_Cartesian System.png

    Purple is the location of my end stops so they are configured for X min, Y max and in my homing files I tell the printer to "home" to back-left corner.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.