New Duet ethernet initialization, firmware upgrade - disaster…



  • So, I'm pretty familiar with the Duets, I have them installed on several printers (WiFi and V0.8.5 versions). I purchased an "ethernet" version so I could run multiple colors using the expansion board (someday, though I'm not sure I bought the right model now… worry about that later).

    I am upgrading an FT5 with all aluminum parts and thought I'd standardize it like my other deltas with the Duet and a PanelDue. I had already fixed up another guys FT5 here at work , with a WiFi Duet so I thought I'd take that config file and use it for mine. That kinda-sorta worked but I wanted to update to the newest firmware and that's where the problems started. Unfortunately now I can't really get anywhere with this thing. My current status is:

    I've gotten the printer to the point where the PanelDue isn't communicating with the Duet, it just says "Connecting".... I've unplugged that for the mean time.

    I can see the device on my computer:

    but I can't connect to it with YAT:

    I've made sure that I don't open anything before YAT that might want to already "use" COM11…

    I got to this point because when I tried to connect to the Duet through the web interface, I was presented with:
    "ERROR! ERROR! ERROR!
    404 - The requested file could not be found."

    I've been farting around with this thing for several hours and I can't figure out what to do now. I've tried holding the erase and the reset buttons to wipe it completely, but the SD card still has files on it, even when I do that. At this point I'd just like to start from scratch if at all possible....

    Ideas please?


  • administrators

    The Erase button erases the firmware in the processor, not the files pon the SD card.

    The "Craft bot firmware loader" is the wrong device driver. So I suggest you run Update Driver and install the driver that you can download from https://github.com/dc42/RepRapFirmware/blob/dev/Driver/DuetDriverFiles.zip (follow that link, then press Downoad). Then the port should appear as "Bossa port" if the firmware is erased, or "Duet" if it is not.



  • Thanks Dave.
    The port still has the same name in the Devices after installing the INF file.
    I can connect with YAT now, but not Bossa.
    When I send M115 through YAT, I get nothing in response.
    I cannot connect with Bossa.


  • administrators

    Looks like you haven't managed to install the driver correctly. Right click on that device and select "Update driver". Then choose "Browse my computer for driver software". Browse to and select the .inf file. Make sure that the .cat file is in the same folder as the .inf file.



  • Thanks for the patient advice as always. Unfortunately, while the name updated (Now called "Bossa Program Port (COM11)"), I still can't connect via Bossa (v1.2.1) to it…
    The Bossa error message is "Could not connect to device on COM11"


  • administrators

    You need to use Bossa 1.18. Older versions don't recognise the SAM4E processor.



  • OK. Newer version of Bossa installed.

    I press Erase on the board.
    Press Reset on the board.
    Board shows up in device manager (BOSSA Program Port (COM11)).
    Run Bossa (1.8).
    Connect to COM11.
    Browse to DuetEthernetFirmware.bin (downloaded from https://github.com/dc42/RepRapFirmware/releases/tag/1.21, released 2 days ago, 327KB).
    In Write Options, I select "Erase All" and "Boot to flash", brownout options are greyed out and I do not select "Lock" nor "Security"
    I click on "write", it writes and reports that it has written successfully.
    I click on "verify", it Verifies and reports that it has verified successfully.

    After that, I'm dead in the water. I'm assuming that it's uploaded properly, but if I hit "reset" on the board, the device will not reconnect. If I reboot the Duet, it will not reconnect. I have to depress "erase" and "reset" again to get it to show back up and I'm back at square 1.


  • administrators

    You should check Lock as well, as stated in the wiki.



  • Checked Lock as well this time. Again, it writes, I can verify it, but after I hit the reset button, the device disappears from my computer and I can't get it to come back until I erase and reset again. I've done the write process three more times and it just disappears once "rebooted".

    On a positive note, I updated my Delta at home that has a Duet WiFi (from 1.12 to 1.21) with no issues, other than having to pop out the SD card in order to add the "www" folder and its contents.



  • Could there be possibly something on the SD card that would cause the Duet to not "show up" after rebooting (hitting the reset button)?

    Also, this is a V0.8.5 board, if that matters…



  • ah sounds like you may have flashed the wrong firmware image which one did you use?



  • I've tried 1.18, 1.19 and 1.21, all called "DuetEthernetFirmware.bin" as I don't see anything specific for the V0.8.5.



  • OMG, I'm an idiot.

    In my defense, I had this board laying around for a few months before I installed it (at work), and I thought it was the "ethernet" version…. I just searched the board for the version info this morning.

    I'm sorry to waste your time everyone (especially Dave).


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.