Protect against out-of-the-bed printing

  • i had some issue… visually it was like printer going crazy and printing line instead of 101010 test cube.
    forum link

    issue was based on the fact that gcode file was out of the bed perimeter. firmware did not check that and printer was trying to print the best it could without any notification.

    i suggest adding some code that will prevent or at least indicate that im trying to print behind the bed end…

  • administrators

    The firmware does check. For a Cartesian, CoreXY or SCARA printer, make sure that you have the correct parameters in the M208 S0 and M208 S1 commands. For a delta printer, make sure that you have the correct B parameter in the M665 command.

  • in my system

    M665 has B75 in config-override.g same in config.g

    in my S3D slicer setup plate size was twice bigger (as a mistake). that definitely produced wrong gcode and tried to print out-of-the-bed.
    that made cube collapsed into line… that messy line was printing.

    no warnings or halt from web server....

  • administrators

    I have just re-tested movement limits on my delta, and they work. The firmware doesn't produce a warning when in FDM mode because it's quite common for the skirt to be outside the limits of the bed; but the firmware limits the movement to be within the bed radius - unless you have used M564 S0 to disable limit checking. You can send M564 with no parameters to enquire whether limit checking is currently enabled.

  • well, i think it does not… i was trying to fit large box.. 🙂

    ... or it is slicer issue?

  • David, I just helped 2 people on my Slack channel in the last 2 days with exactly this problem. I think a simple warning message in the console would be a good idea to help diagnose issues. Even with an out of bound skirt, a message would give the user some clue as to what is going on.

  • administrators

    Added to the firmware wishlist.


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.