Updating main firmware



  • Hi

    I bought a duet Wifi and I can not get it up and running. I can not get Updating the main firmware as Duet Wifi not bother to communicate with Adrunio IDE 1.6.1 or promterface. I've also tried with SAM-BA as described in the guide. guidenhttps: //duet3d.com/wiki/Updating_main_firmware.
    Is the board broken or what do i wrong?

    Greeting Dennis.


  • administrators

    If you are running Windows, open Device Manager, expand Ports Com & Lpt, and see if a new com port appears when you plug in the Duet.

    If it shows up as Duet 3d Printer Electronics then you should be able to communicate with it using Pronterface.

    It it shows up as Bossa Port then you need to use sam-ba to install the firmware.

    If it doesn't show up at all, press the Erase button for a second then the Reset button. This should make it show up as Bossa Port.

    If it still doesn't show up then one or more of the USB cable, the USB port on the PC and the Duet is faulty. If you tell is which LEDs on the Duet are illuminated, that may help diagnose the problem.



  • When I connect Duet Wifi to a PC, it looks like Bossa in Device Manager. But when I try two communicate with Duet Wifi through Bossa Programme Coming Bossa with an error message "could not connect two COM3" though Duet wifi is connected to COM3.

    The LED's is illuminited red is Diag, 5v + and USB. The last LED is illuminated green is 3.3v.

    I hope it can help you diagnose the problem



  • BOSSA does not work with DuetWiFi you need to use Sam-BA as per DC42's post above Check the Wiki in the Firmware section


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.