Duet Wifi not updating firmware when installing 2.0



  • My Duet Wifi board is currently

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 1.21 (2018-03-21)
    WiFi Server Version: 1.21
    Web Interface Version: 1.21.1

    (FROM DWC)

    When I try to update to Firmware 2.0, It says the firmware is being updated. When the firmware finishes updating, It still only shows Firmware version 1.21. I've been using the Duet2CombinedFirmware.bin. I'm not sure if i'm doing something wrong. Any help would be appreciated. Thanks


  • administrators

    Without a PanelDue connected to show the status as the firmware update progresses, it's hard to know what is going wrong. One possibility is that you have a very old version of iap4e.bin on the SD card. So try uploading the latest iap4e.bin first, then try the firmware update again.



  • Thanks. That's what the problem was. Updated iap4e.bin and then applied the duet2combinedfirmware.bin. It worked as expected. Thanks for the help.



  • I am also having this problem, but the iap4e file is the newest version. Any other possibilities? Thanks!

    Edit: Solved. Uploaded the firmware a few more times and eventually it worked.


  • administrators

    Anyone upgrading to 2.0 from a firmware version prior to 1.21 needs a further piece of information. At version 1.21 the name of the firmware binary for the Duet WiFi and Duet Ethernet was changed to Duet2CombinedFirmware.bin. But if your existing firmware is older than 1.21 then it will expect a different firmware binary filename. So after downloading Duet2CombinedFirmware.bin, you will need to rename it to either DuetWiFiFirmware.bin or DuetEthernetFirmware.bin in order to install it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.