Little Monster -s hort to ground



  • @infamous_panda
    Monster works perfect with Duet Wifi.
    If you want the config files, let me know.



  • Yes yes yes!

    can you show me which version of bltouch you have, if you used a bltouch?



  • @dc42 hi, you would not happen to know where M3D keeps their version? Is is something that needs to be requested?



  • @autsch that would be helpful for me as well


  • administrators

    @infamous_panda said in Little Monster -s hort to ground:

    @dc42 hi, you would not happen to know where M3D keeps their version? Is is something that needs to be requested?

    Try https://github.com/PrintM3D/RepRapFirmware. Branch feature/full12864 has some binaries in the EdgeRelease folder.



  • @dc42

    Checked my wiring and for debris. The board is floating on standoffs so nothing contacting underneath. All seems in order. I did move the X axis to the extruder as recommended. My short to ground error has moved from the driver 0 to now on driver 2 (Z). The problem seems to arise about 10 - 15 minutes into a print.

    Questions.

    What should I try and in what order to get this sorted.

    Older firmware (M3D's)?
    Different power supply?
    Lowering print speed?
    Increasing current?
    Other?

    Could this be a bad board?

    Also is there a way to automatically stop the print once the board detects this error. The issue is right now I have to stand right in front of it while it's running. Once the error occurs it disables that motor but the other continue to move causing the head to start slamming into things.


  • administrators

    As the problem isn't reported until 10-15mins into a print and has moved to the Z motor, I am wondering whether the firmware is mis-reporting an over-temperature warning or some similar condition as a short to ground. What current do you have the motors set to (M906 command)? How hot are the driver chips getting? Can you confirm that you are using version 2.01 firmware from https://github.com/dc42/RepRapFirmware/releases?

    I have been controlling my Cartesian printer with a Duet 2 Maestro for nearly 6 months, without issue. I am running the Y motor at 1000mA and the other motors at 800mA (the motors are all rated at 1.33A).



  • I am running a delta machine. Currents are 1300 for all the axis and 1100 for the extruder. idle factor 30%

    Yes firmware is the latest. 2.01 How would I be able to tell the temperature of the driver chips? Is there are sensor onboard? I have seen other threads where over temperature is actually reported. I get no such message.

    My motors are barely warm should I increase current?



  • If not yet currently possible, Can I request that there be an option to automatically stop printing once catastrophic errors are detected. Like short to ground?



  • Tried to run another print this time at 70% speed. It ran a little longer but eventually failed getting the error on driver 1 this time.


  • administrators

    At 1300mA current you must to use a fan to cool the driver chips on the Maestro. This is necessary for all current Trinamic drivers with internal mosfets, except for the TMC2660. The smaller Trinamic drivers are best used with 24V power and lower current motors - just as Prusa has done on the i3 Mk 3.

    However, the firmware should report over-temperature warning, not short-to-ground, some time before you start losing steps. I will test the behaviour at high currents with insufficient cooling again.

    Until you can add a fan, you may find that reducing the current to about 1100mA avoids the problem.



  • @dc42 hi I do have a fan blowing directly on the board it may be the temperature is fine.



  • @dc42 there seems to be no loss of steps. The axis just suddenly shuts down once the error shows up but the other two motors keep going.



  • Okay,

    Tried lowering the current. No effect
    Increased the fan speed. No effect.
    Added heatsinks to the drivers. No effect.

    Bought new 0.9 deg steppers and crimped on duet connectors. Problem Happens even earlier.

    Anything left to try? I'd like to warranty this board with M3D. They have a very poor response rate for support or even to ask how one gets a refund.


  • administrators

    @infamous_panda, I'll re-test the behaviour of the firmware when the stepper driver chips overheat late today.



  • @dc42

    I am skeptical that this is a thermal issue, but look forward to your findings. Here is the picture of the setup currently.

    0_1534250854592_IMG_20180814_084014.jpg
    0_1534250861243_MVIMG_20180814_084023.jpg

    There is a large always on fan on top of the electronics housing. It is being fed with 24V.

    The heatsinks were added recently but seem to have no effect. I have tried currents ranging from 800 to 1500. I replaced the XYZ motors with brand new 0.9 deg steppers and it actually seems to fail sooner.

    I recently started experimenting with lower speeds in the config, which has shown some promise. Could having too high maximum speeds cause this error? It seems to happen when the machine is asked to do a rapid non print move.

    The stock settings for this machine translated from smoothieware with the MKS SBASE are

    M566 X1200 Y1200 Z1200 E3000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X39960 Y39960 Z39960 E3000 ; Set maximum speeds (mm/min)
    M201 X5000 Y5000 Z5000 E1500 ; Set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1500 E1300 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    I looked at the config.g file for some others on the Duet Little Monster Facebook group and they seem to have much lower values on the speeds. Though the current values range from 1200 to 2000. I replicated the speeds below and have been experimenting with the current. Below is what it is presently.

    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1400 Y1400 Z1400 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    I have not succeeded in printing a benchy yet. But it seems to be getting further and further into the process.


  • administrators

    @infamous_panda said in Little Monster -s hort to ground:

    There is a large always on fan on top of the electronics housing. It is being fed with 24V.

    It's more important to cool the underside of the board than the top. see https://duet3d.dozuki.com/Wiki/Mounting_and_cooling_the_board#Section_Cooling.



  • @dc42 Right I did see that. There is certainly some flow going underneath. The cover I would eventually design would have the exhaust at the bottom so that air would be forced to pass underneath.

    With respect. Can you tell me why you are pursuing a thermal source of error? I have tried multiple currents now some very low.

    I willing to try other paths. But It seems likely that this is a bad board. I need some resolution soon as I will be traveling and will miss my window to request a refund/replacement. I'm really at a point where I would just get the full blown Duet (since I chopped off the old connectors).

    Let me ask directly. What is the likelihood that this is a bad board, given the avenues already explored?


  • administrators

    My other concern is that with a large fan pointing directly at the board like that, I suspect there will be a dead zone around the centre of the Duet with very little airflow.

    Had the error occurred on only one driver, I would have said it's almost certainly a bad driver chip. But you've seen the problem on 2 different drivers.

    I am about to re-test the firmware response to a driver overheating.


  • administrators

    I have tested the response to driver overheating on the Maestro. When the driver signals an over temperature warning, this shows up in the M122 status report. However, it does not send the messages to DWC that it is supposed to send.

    So my guess is that the drivers are overheating, but you are not aware of this because of the broken warning reporting code. I suggest you try sending M122 regularly while running a print and check the driver status for over-temperature warnings.

    I'll fix the warning code in the next 2.02beta release.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.