homing is not working correctlly after update Delta



  • Just updated everything to the latest release my issue at the moment, is when ever the printer is homed. The arms are moved about 100mm down wards, and the printer assumes that's where the homed origin is. Im not sure what went on during this upgrade. I came from firmware 1.92 and had no issues before. I fixed a minor issue with my homing switches not working. But this is getting to be a headache. Can some one maybe help me source where my code might be off?

    Config file

    ; Configuration file for Mini Kossel kit from Think3DPrint3D for testing Duet WiFi

    ; Communication and general
    M111 S0 ; Debug off
    M550 eddygara ; Machine name (can be anything you like)
    M551 Bigge4life ; Machine password (currently not used)
    M552 S1 ; Enable WiFi
    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Set auxiliary serial port baud rate and require checksum (for PanelDue)
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    ; Axis and motor configuration
    M569 P0 S1 ; Drive 0 (X) goes forwards
    M569 P1 S1 ; Drive 1 (Y) goes forwards
    M569 P2 S1 ; Drive 2 (Z) goes forwards
    M569 P3 S0 ; Drive 3 (E0) goes forwards
    M569 P4 S0 ; Drive 4 (E1) goes forwards
    M574 X1 Y1 Z1 S1 ; all endstops at high end, active high
    M665 R138 L300.15 B140 H364.3 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E92.51 ; Set axis steps/mm
    M906 X1250 Y1250 Z1250 E1000 ; Set motor currents (mA); set each extruder explicitly
    M906 I40 ; Set motor idle factor to 100% while testing so they don't idle at all
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2) Set all E-motors the same
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min) Set all E-motors the same
    M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute. Set all E-motors the same

    ; Thermistors
    ; Duet0.8.5 uses 4.7K resistors
    M305 P0 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the 1st nozzle thermistor ADC correction
    M305 P2 T100000 B4267 R4700 H30 L0 ; Put your own H and/or L values here to set the 2nd nozzle thermistor ADC correction
    M305 P3 T100000 B4267 R4700 H30 L0 ; Put your own H and/or L values here to set the 3rd nozzle thermistor ADC correction
    M305 P4 T100000 B4267 R4700 H30 L0 ; Put your own H and/or L values here to set the 4th nozzle thermistor ADC correction
    M305 P5 T100000 B4267 R4700 H30 L0 ; Put your own H and/or L values here to set the 5th nozzle thermistor ADC correction
    ;M305 P6 T100000 B4267 R4700 H30 L0 ; Put your own H and/or L values here to set the 6th nozzle thermistor ADC correction

    M570 S250 ; Hot end may be a little slow to heat up so allow it 180 seconds

    ; Tool definitions FOR stock SeeMeCNC hot end - Tool 0.
    M563 P0 D0 H1 F0 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures

    ;*** If you have a dual-nozzle build, un-comment the next 2 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures

    ;*** With a Duex 4 add 3 more tools
    ;M563 P2 D2 H3 ; Define tool 2
    ;G10 P2 S0 R0 ; Set tool 0 operating and standby temperatures

    ;M563 P3 D3 H4 ; Define tool 3
    ;G10 P3 S0 R0 ; Set tool 0 operating and standby temperatures

    ;M563 P4 D4 H5 ; Define tool 4
    ;G10 P4 S0 R0 ; Set tool 0 operating and standby temperatures

    ;M563 P5 D5 H6 ; Define tool 5
    ;G10 P5 S0 R0 ; Set tool 0 operating and standby temperatures

    // Z probe and compensation definition
    ;*** If you have an IR zprobe instead of a switch, change P4 to P1 in the following M558 command
    ;*** FSR is a switch, so set to P4! Is H3 important?
    M557 R138 S20 ; define a grid with the specified radius and spacing (for delta printers)
    M558 P1 X0 Y0 Z0 ; Z probe is a switch and is not used for homing any axes
    G31 X0 Y0 Z1.487 P500 ; Set the zprobe height and threshold (put your own values here)

    M208 S1 Z0 ; set minimum Z
    ;
    T0 ; select first hot end

    M106 P1 T45 H1

    home file

    ; Homing file for RepRapFirmware on DangaLang2000
    G91 ; use relative positioning
    ;******* Change F250 in the following line to F2500 when you are finished commissioning
    ;******* Change 320 in the following to a higher value if your Kossel has taller towers
    G1 S1 X1195.30 Y1195.30 Z1195.30 F2500 ; move all carriages up 1195.30, stopping at the endstops
    G1 S2 X-3 Y-3 Z-3 ; move all carriages down 3mm
    G1 S1 X6 Y6 Z6 F250 ; move carriages slowly up 6mm, stopping at the endstops
    G1 Z-5 F2000 ; down a few mm so that we can centre the head ; back to absolute positioning
    G90
    G1 X0 Y0 F2000 ; centre the head and set a reasonable feed rate

    bed probe file

    ; Auto calibration routine for delta printers
    ; Before running this, you should have set up your zprobe Z offset to suit your build, in the G31 command in config.g.

    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G31 X0 Y0 ; don't want any probe offset for this
    G28 ; home the printer

    ;*** Remove the following line if your Z probe does not need to be deployed

    ; The first time the mechanical probe is used after deployment, it gives slightly different results.
    ; So do an extra dummy probe here. The value stored gets overwritten later. You can remove this if you use an IR probe.

    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 10 points, 6 factors, probing radius: 127, probe offset (0, 0)
    G30 P0 X0.00 Y127.00 Z-99999 H0
    G30 P1 X109.99 Y63.50 Z-99999 H0
    G30 P2 X109.99 Y-63.50 Z-99999 H0
    G30 P3 X0.00 Y-127.00 Z-99999 H0
    G30 P4 X-109.99 Y-63.50 Z-99999 H0
    G30 P5 X-109.99 Y63.50 Z-99999 H0
    G30 P6 X0.00 Y63.50 Z-99999 H0
    G30 P7 X54.99 Y-31.75 Z-99999 H0
    G30 P8 X-54.99 Y-31.75 Z-99999 H0
    G30 P9 X0 Y0 Z-99999 S6

    Thanks!!



  • Heres something strange i noticed trying to debug this.

    My homed heights are all over the place, even though the arms are all homed at the same psychical location.

    0_1533626117611_Untitledfg.png


  • administrators

    @eddygara said in homing is not working correctlly after update Delta:

    Just updated everything to the latest release my issue at the moment, is when ever the printer is homed. The arms are moved about 100mm down wards, and the printer assumes that's where the homed origin is.

    Do you mean that it does that instead of moving the carriages up to the endstop switches, or after moving the carriages up to the endstop switches?



  • @dc42 After i home the printer. instead of moving too its start position, (usually 5mm below the endstops). The printer moves about 100mm down and then set that position as its resting home position. with the values
    you see above in the photo, though they vary.



  • Thanks for the help the issue was not having M564 H0 in my config file. Your "list of changes" page only describes this issue with Cartesian printers. Not delta's, so i was bit confused. I know you have a ton on your plate so again thanks for everything you do!

    For anyone reading this, i have a delta with motors on the top of the printer. I had to change all my stepper motors too the opposite setting to get them to work again.

    example

    M569 P0 S1 ; Drive 0 (X) goes forwards
    M569 P1 S1 ; Drive 1 (Y) goes forwards
    M569 P2 S1 ; Drive 2 (Z) goes forwards
    M569 P3 S0 ; Drive 3 (E0) goes forwards

    Had to change is to

    M569 P0 S0 ; Drive 0 (X) goes forwards
    M569 P1 S0 ; Drive 1 (Y) goes forwards
    M569 P2 S0 ; Drive 2 (Z) goes forwards
    M569 P3 S1 ; Drive 3 (E0) goes forwards

    and then add

    M564 H0 at the end of my Config file in order to get my printer to home correctly. Also if you have code written for a probe that has to be deployed, but you are not using one on your printer. Remove it, it messes with the printers movement for some strange reason.


  • administrators

    @eddygara said in homing is not working correctlly after update Delta:

    Thanks for the help the issue was not having M564 H0 in my config file. Your "list of changes" page only describes this issue with Cartesian printers. Not delta's, so i was bit confused. I know you have a ton on your plate so again thanks for everything you do!

    On a delta printer, normal G0/G1 moves without S parameter are never allowed before homing, so M564 H0 doesn't apply except to any additional axes you create.



  • So what changed is this firm ware update that now renders my Printer to not home correctly. Or keep it's position?

    After I add those 2 lines of code my Printer started to home correctly and and not move out of place. But after I reconfigure my Z=0 line. And home once again. The printer almost doubles it's homed height from whom to 720mm. Even though it only moved 360mm. What could be causing this?

    You tell me what doesn't work etc. But not really giving any solutions. Sorry it's just frustrating because this is holding up the work of 3 printers.


  • administrators

    You said you came from firmware 1.92, but that version does not exist. Did you mean 1.19.2?

    The M569 changes you say you had to make can't be anything to do with firmware, because there have been no changes to the directions of motor movements since about version 1.09. My guess is that you disconnected the motors, and when you reconnected them you plugged them in with the connectors the opposite way round.

    The only explanation I can think of for your printer doubling its homed height is if you are loading a height map before homing, and that height map has a large offset in it.


Log in to reply