upgrade issue



  • Hello I just started playing around with this stable release 2.01. I have a probe the bl touch mini. It works fine and now after switching to the upgrade I am seeing the probe blink. I can deploy and probe pin fires down, turns blue. I retract and probe retracts, but it should change back to solid red. It goes to blink state after retract. I read about changing the P7 to a P9 but that doesn't seem to change my result. Would any one who knows about this be willing to help a newbie with this issue? I would really appropriate the help


  • administrators

    1. Please confirm that you are sending M401 and M402 to deploy and retract the probe.

    2. Please post the contents of your deployprobe.g and retractprobe.g files.

    3. Please confirm how you have wired the BLTouch to the Duet.



  • @sir-printsalot said in upgrade issue:

    bl touch mini

    I've never heard of a BLTouch mini. Can you please post a picture of the probe? There are many different versions of the BLTouch, both authentic and cloned. It would be useful to know specifically what hardware you have, as they are not all created equally.



  • yes I am using m codes As you have out lined. Wiring is correct and it's the brand name probe. It has been working 10 months at least everyday. After a power cycle I got it working. I thought things where good, but printer didn't home before print and I stopped it before a crash. Testing printer, I found probe only works directly after a power cycle. If I run another command of any type and than try homing again, probe will not deploy the second time. Power cycle and it will one time. My slicer is setup with homing command and I use store height map. But printer running this code doesn't honor the g28 command in print Gcode. It does when I use the DWC buttons for home all. Please keep in mind that this is a long term well running printer and no other files, setting or mechanical items have been changed. I only up loaded the 2.01 firmware and duet/DWC did the update. DWC version is 1.21.1

    My main concern is the inconsistency of the probe deploy during z homing.
    General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    G31 X-52 Y50 Z.9 P25
    M208 X0 Y-21 Z0 S1 ; Set axis minima
    M208 X305 Y291 Z247 ; Set axis maxima

    M574 X1 Y1 S1 ; Set active low endstops
    M574 Z0
    M558 P9 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y12 Z.96; Set Z probe trigger value, offset and trigger height
    M557 X52:300 Y60:335 S40 ; Define mesh grid

    ; deployprobe.g

    ; M401 has never worked only M280 P7 S10 heater 7
    ;deploy probe command
    M280 P7 S10 ;I1 listed for use but doesn't seem to work

    ; Relative positioning
    G91
    G1 Z5 F3000 ;lift Z 5mm
    G1 X-295 y-302 F1500 S1 ;relative move to x,y -295mm neg dir stop at switch
    G1 X5 Y5 F1000 ;relative back off switch 5mm pos dir
    G1 X-295 Y-302 F360 S1 ;relative move x,y -295mm alliance neg stop at switch slowly
    G90 ;absolute moves
    G1 X148.5 Y151 F2000 ; put probe center of bed
    M280 P7 S10 ;run deploy probe macro
    G30 ;lower probe set height
    M280 P7 S90 ; run retract probe macro



  • My mistake it's the BL Touch smart. Antclabs hologram label on box I bought it from Filastruder when they still carried them.



  • Head Movement
    Extruder Control
    Feed amount in mm:
    Feedrate in mm/sec:

    Ok now I have a connection issue to add to my earlier post. Uggg

    User-Defined Macros
    Connect to your Duet to display Macro files
    Miscellaneous
    35 %
    JavaScript Error

    A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:

    Version: 1.21.2-dc42
    Message: TypeError: rememberedGCodes.indexOf is not a function
    URL: http://192.168.1.4/js/dwc.js
    Line: 1133:52
    Error object: {}



  • How exactly do you have the BLTouch wired?

    You said you used M558 P7 before and now switched to P9. Is the BLTouch connected to the Z endstop input? Using P9 requires it to be connected to the Z probe input.



  • To try and clear the Java script error load the DWC after a reboot, go to the settings page, click load factory defaults and restart.


  • administrators

    Deployment and retraction of the probe is handled automatically by the firmware, so you should remove the M280 commands from your homing and bed probing files, leaving just the ones in deployprobe.g and retractprobe.g.



  • The probe is connected to probe pin. Servo driven off heater 7 on the expansion header breakout board.
    Probe uses m280 p7 s10 deploy, m280 p7 s90 retract, m280 p7 s160 test/reset. the p7 in this code = h7 servo channel 7. m307 h7 a-1 c-1 d-1 command to use heater 7 as servo output.

    How than does the probe deploy if I remove the m280 commands?

    I have power cycled the board and reloaded the DWC many times over 2 days. I tried reset factory default, apply setting as well. I get the java error every time I try. Not always right away, but within 5 minutes or so. I tried 1.21.1, 1.21.2, and 1.22. all 3 of these DWC versions throw this error. Probe is now back to non functioning altogether. Plus if I upload a print file duet waits for heaters and goes straight to print moves without homing. 28 command comes first than g29.1 after that. Printer just starts printing. The some axes are not homed indicator is present on DWC screen when this is going on.

    I have an sd card with 1.19.1 firmware and 1.15 DWC loaded. I reloaded these versions back to board and everything works perfect. I only changed p9 back to p7 for probe. No java error, printer obeys homing command from slicer and probe works perfectly. I just wanted to stay current with my setup, but I guess things aren't ready yet for me to use the new stuff. Maybe when these version are more stable I might be able to figure them out.



  • I can't get past the java script error gcode is not a function. I erased all gcode from gcode folder and did a fresh install completely erasing board. I used programmer to burn boot loader and only installed the required files for version 2.01rtos firmware and web interface 1.22. Now I cannot get beyond this java script error. cycling power clears message. I restore factory and confirm applied values. Type anything in gcode window and java script gcode is not a function. I followed the " in the mean time instructions" to work around it, but failed. I'm not a quitter, but I know when I'm beat. I never thought you had to be a programmer to 3d print. This stuff is just beyond what the average person interested will be willing to deal with. I'm not sure why it has to be so manual and complicated to use. Owe well, thanks for your time, but this system has too many complications and reading over the many post it seems that there are too many issues wrong to enjoy using the printer and far too many hours trying to config, maintain it. I really thought this would be a fun thing for my family.



  • A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:

    Version: 1.22
    Message: TypeError: rememberedGCodes.indexOf is not a function
    URL: http://192.168.1.50/js/dwc.js
    Line: 1175:52
    Error object: {}

    What does line 1175.52 indicate? I wiped everything from the entire system containing gcode files.



  • ok I down graded to dwc 1.21.1 and java error went away. Now the problem is hitting the home all or any single homing button throw an error G0/G1 axis not homed error. As if I'm trying to jog without homing, but I'm trying to home. What exactly is going on because every single function doesn't work. I'm being blocked around every corner here. I mean nothing is working no matter what version I use newer then 1.19.1 firm and 1.15 dwc those are the only ones that work with my 1.02 duet Ethernet board.



  • @sir-printsalot said in upgrade issue:

    How than does the probe deploy if I remove the m280 commands?

    The m280 commands will be in the deployprobe.g and retractprobe.g files. The system can then handle the deployement and retraction on it's own when using the P9 probe type for the BLTouch. You can manually call those macros with M401 and M402. This allows the system to keep track of the deployment state of the pin. This is only the case when using the P9 probe type which is dedicated to the BLTouch.

    The some axes are not homed indicator is present on DWC screen when this is going on. G0/G1 axis not homed error.

    This is due to a change made in 1.21 that prevents the movement of axis until they have been homed. It is intended to prevent unintentionally ramming the print head into a physical endstop.

    From the release notes:

    On Cartesian and CoreXY printers, normal G0 and G1 moves are no longer allowed before the corresponding axes have been homed. In particular, if your homex.g, homey.g and homeall.g files raise Z a little at the start and lower it at the end, you will need to add the S2 parameter to those G1 Z moves. Otherwise the G1 Z move will be refused unless Z has already been homed and the homing macro will be terminated. If you want to allow axis movement prior to homing, put M564 H0 in config.g.

    The key part in your case is at the end. If you want to allow axis movement prior to homing, put M564 H0 in config.g. That will return it to the old expected behaviour.

    Upgrading through so many versions at once can be tricky since so many things can change between releases. Sorry that caught you off guard.
    https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md



  • @sir-printsalot said in upgrade issue:

    Owe well, thanks for your time, but this system has too many complications and reading over the many post it seems that there are too many issues wrong to enjoy using the printer and far too many hours trying to config, maintain it. I really thought this would be a fun thing for my family.

    Sorry you got caught up in an upgrade headache. Please return if you'd like to give it another crack.



  • Why does it feel like I'm not the one giving up? Why does it feel like I am the only one that believes these issues are actually happening? I have provided every thing requested and responded fast to questions. If I had something to give back I would, but my knowledge is limited. Is there a place to pay for software that someone else configures? I think kindness take you so far than you gotta reach for the wallet. Who needs work because there is an answer somewhere?



  • Ok I missed the second to last reply you left. Sorry you explained the reason/function better as to the m280 m401 thing. Thank you for that. My last post sounded bad please forgive me. As to the movement before homing code that gets added, it's sure sounds a lot like a firmware lock. I can't home not even x or y. If it's to prevent movement before homing than that code needs not be over-ridden before a homing event takes place. I can't home without that code added. Added I can jog and crash. It seems like code added just to add more code to over-ride itself with no usable benefit. I can't do anything without, and crash end stops with it. I'm not even speaking of the probing issue. I removed z lift and tried y homing by itself and no go. I added the s2 to this homing command. Again no Go. I keep getting additional info and my hopes up together, but nothing will allow a single function to perform. This machine is so foreign to me now, I don't know it.

    Has there ever been a firmware interface combo that didn't produce false error and actually allow basic height run prints? If so forget this new stuff I want basic printing with bed auto leveling.

    now I'm stuck with it in erase no firmware on board. I did this earlier because firmware downgrade didn't reflect any change. Now I tried going back from 2.01 to 1.19.1 what I was using and bossa port programming is now longer responding.



  • @sir-printsalot said in upgrade issue:

    If it's to prevent movement before homing than that code needs not be over-ridden before a homing event takes place.

    Exactly. The preferred way to handle this is to add S2 to any non-homing moves in your homing files so that they are allowed. This usually applies to raising the head or lowering the bed a bit before homing X and Y. This method has the benefit that the jogging commands or through gcode won't be able to crash the head. This was the intention of the change at any rate. If you'd like to go this route, you can post your homing files and I can tell you what you need to change. Or you can use the following example to modify it yourself.

    homeall.z
    G91                     	; relative positioning
    G1 Z5 F200 S2        		; Lower bed 5mm to ensure it is below the switch trigger height, use S2 switch to allow movement without homing.
    
    ; Home XY for CoreXY
    ;
    G1 S1 X-375 Y305 F4000   	; course home X or Y Use S1 switch to seek endstop
    G1 S1 X-375 F4000              	; course home X
    G1 S1 Y305 F4000              	; course home Y
    G1 X5 Y-5 F1000             	; move away from the endstops
    G1 S1 X-10 F600           	; fine home X
    G1 S1 Y10 F600               	; fine home Y
    
    ; Z homing section for BLTouch follows
    ;
    G90				; absolute positioning
    G1 X190 Y90 F6000		; Move x and Y axis over to bed center 
    G30				; Probe again to get a more accurate position
    

    Alternatively you can add M564 H0 to config.g to allow all moves without homing entirely. If you have added that and it still doesn't work, please send M564 in the console and report the reply.



  • Sorry, just to back up a bit, I am unclear on what state your board is currently in. Are you in a state where you can power on the board and reach the DWC?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.