Cannot update Firmware



  • hello , so I wanted to report an issue of my printer stopping mid print with the message: Cannot read file, error code 1. Cancelled printing file Y-carriage_MGN9-H_MOUNT.gcode, print time was 0h 37m
    But now i have another issue.

    I replaced the sd card. reuploaded the gcode with no success.
    As a last messure i wanted to update the firmware (even though it already was the latest firmware) and everything pretty much broke. No web interface. no connection via pronterface. So i downloaded SAM-BA and did everything according to the installation guide and at least a can connect now via pronterface, but still no web interface. when i run the m997 s0 command, the printer wont reconnect afterwards.
    latest version of iap4e.bin didnt help either.

    Can someone please help?

    I have a DuetEthernet Board
    CoreXY configuration
    0_1536336869731_config.g

    versions before the pain: https://gyazo.com/4cd6a9ebc7422cdaf359a69bcb0ee0f7


  • administrators

    I'm sorry to hear that you are having problems.

    You said that after flashing the firmware using SAM-BA, you can connect via Pronterface; but if you then send M997 S0 then you can't reconnect afterwards. That sounds like either your Duet2CombinedFirmware.bin file or just possibly the iap4e.bin file on the SD card is corrupt, or that there are problems reading from the SD card.

    If you flash the firmware using SAM-BA and connect Pronterface:

    • If you send M503 from Pronterface, do you get a listing of the config.g file? If not then there is something wrong with the SD card or the SD card interface.
    • if that works, if you then send M552 S0 followed by M552 S1 from Pronterface, do the LEDs on the Ethernet port flash, and do you get a message back a few seconds later, giving the IP address? If not, what is the response from sending just M552?


  • Following your instructions allowed me to start the web interface. Why is it, that it wont start automaticly? Sending the M552 command says:
    Network is enabled, configured IP address: 0.0.0.0, actual IP address: 192.168.1.118

    I flashed the firmware again through the web interface and now it works normaly. The web interface starts normaly aswell and can connect anytime using pronterface. I still dont know what the exact issue was but ill post here if it fails again.

    Before you replied I redownloaded iap4e.bin und put it on the sd card, maybe that had en effect?

    Thank you very much for your help. 😄



  • @xenjamo it's a good idea to verify the file size of things downloaded from GitHub. I don't know why but it seems to have a chronic problem of delivering partial files. I've never seen any other site do it so frequently.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.