New Duet Web Control 1.14 and RepRapFirmware 1.17a-ch





  • so far so good… love the height map.

    nice work you guys.

    thanks for working so hard so the rest of us can create and make new thing with your improvements 🙂

    is there a way to save the height map as an image? i can right click on the scale image and "save as" but i have to screen capture to save the height map.

    ~Russ



  • Firstly, thanks a lot for your work on this.

    A suggestion: how about changing the colour of the -ve peaks in the heightmap image to something other than red (I suggest blue) so that when you view the map from above you can tell which areas are high and which are low.


  • administrators

    @roboduet:

    Visual representation of height map will not be available for the "standard" N-factor delta calibration (using a G30 command)?

    The 3D visualisation is triggered either by the final G29 output or by the "Bed equation fits points …" response that comes up after the final G30 S command has been processed.

    @Russ:

    is there a way to save the height map as an image? i can right click on the scale image and "save as" but i have to screen capture to save the height map.

    At the moment you can only save the grid view by taking a screenshot. If more people request this feature, I can add it to the next DWC version.

    @burtoogle:

    A suggestion: how about changing the colour of the -ve peaks in the heightmap image to something other than red (I suggest blue) so that when you view the map from above you can tell which areas are high and which are low.

    I don't really see the need for this, because we already have the 2D grid to reflect an even bed. If you see the grey lines above the coloured grid, you know the Z coordinates under these points are negative, else they're positive. I guess it wouldn't be impossible to implement a different colour scale in a future version though.



  • @chrishamm:

    I don't really see the need for this, because we already have the 2D grid to reflect an even bed. If you see the grey lines above the coloured grid, you know the Z coordinates under these points are negative, else they're positive. I guess it wouldn't be impossible to implement a different colour scale in a future version though.

    That's true but, personally, I find the grid lines rather confusing when the view is from overhead. I find it difficult to work out which parts of the map are above and which are below the grid. Blue lakes and red mountain tops would be easier to interpret.



  • burtoogle wrote
    A suggestion: how about changing the colour of the -ve peaks in the heightmap image to something other than red (I suggest blue) so that when you view the map from above you can tell which areas are high and which are low.
    I don't really see the need for this, because we already have the 2D grid to reflect an even bed. If you see the grey lines above the coloured grid, you know the Z coordinates under these points are negative, else they're positive. I guess it wouldn't be impossible to implement a different colour scale in a future version though.

    I really would like this feature as well. It would take all the guess work out of it for us older gents with bifocals.



  • I am having multiple "SetPositions called when DDA ring not empty" in the log while printing
    What is causing it and what does it mean?


  • administrators

    @Jackal:

    I am having multiple "SetPositions called when DDA ring not empty" in the log while printing
    What is causing it and what does it mean?

    That indicates that something is happening that I did not expect to happen. Are you running firmware 1.17a or 1.17a-ch? Can you make the gcode file available?



  • I was running on 1.17a-ch, 1.17a does not show such problem.
    Here is the file, it's a bit large.
    https://www.dropbox.com/s/yrw160n6cmfgp5r/PART_3%2B4.gcode?dl=0

    I have stopped my 1.17a-ch print since I got a bad first layer and I am now printing on 1.17a


  • administrators

    @Jackal:

    I was running on 1.17a-ch, 1.17a does not show such problem.
    Here is the file, it's a bit large.
    https://www.dropbox.com/s/yrw160n6cmfgp5r/PART_3%2B4.gcode?dl=0

    I have stopped my 1.17a-ch print since I got a bad first layer and I am now printing on 1.17a

    That's one for chrishamm to look at then.


  • administrators

    Thanks for that file, I'll check if I can reproduce your problem.



  • Chris, is there any plan to make online editing for the G code files available?

    I would think it would be easy, just like editing the other things like macro and system files.

    I find my self wanting to make simple changes to a g code file but have to re upload every time.

    Thanks!!

    ~Russ



  • also it might just be me, but when i try to download a Gcode file that is in a folder, i get "File not found"

    just pointing this out.

    also something very strange. is going on when i run a print. i have pause commands in my files and when the pause command is ran everything locked up. web interface, PanelDue, its a forced restart by pulling power???

    very strange.

    when i Pause the print with the M25 command from buttons. its fine. only when its in the g code its self???

    oh yeah, its busted. same exact file, one with an M25 in there and one with out. just locks up. STRANGE

    can some one else else test this?

    Thanks!!

    ~Russ



  • I get this message repeatedly (multiple times per second sometimes) when printing using these builds on a Duet WiFi:

    SetPositions called when DDA ring not empty

    I definitely wasn't seeing this prior to the update. The machine seems to be functioning, I haven't printed anything significant but it has printed a few calibration pieces fine.



  • I have another problem with chrishamm's build.
    I got M557 command right before my G29 probe in my bed.g
    but when I run it it shows error that my grid was not defined
    The same bed.g works fine in David's build.
    Maybe something to do with the code queue or buffering?


  • administrators

    Thanks for your feedback so far! I have just put another firmware build here: https://www.dropbox.com/s/xkw0f3xxdunposk/RRF-1.17a%2B1.zip?dl=0
    This one should fix issues with M226, G92 (i.e. the SetPositions problem) and M557. Please let me know if this resolves your problems.

    Russ, you're saying you get a "File not found" error message when you try to download a file from the Duet. Can you tell me what board you're using and what the name of your file is? I'd like to be able to reproduce your problem so I can fix it as well.

    G-code file editing except on the macros+sys pages is not on my TODO list, but I may implement that when I add checkboxes to the file pages.



  • I am about an hour into the print with 1.17a+1, everything seems fine.
    Both the SetPositions and M557 problems are gone.
    Great work



  • @chrishamm:

    Russ, you're saying you get a "File not found" error message when you try to download a file from the Duet. Can you tell me what board you're using and what the name of your file is? I'd like to be able to reproduce your problem so I can fix it as well.

    I'm using a DuetWifi V1.0

    when i get the "File not found" error, its only when I'm in the Gcode section of the web interface. & the file Must be in a folder. It dose not matter what file. as long as its not in the root gcode folder. ( i have other folders that i keep G code file's organized, its the files in those folders that show the error when clicking download) im guessing that its just not grabbing the directory correctly? if its in the root Gcode folder its fine…

    @chrishamm:

    G-code file editing except on the macros+sys pages is not on my TODO list, but I may implement that when I add checkboxes to the file pages.

    it would be extremely helpful if there was an edit function. re uploading all the time for a simple change like editing something in the start script is a pain,

    so an edit option would be very helpful.

    i think i heard others say it was good also in another thread a while back.

    [h]also,[/h] did you see my strange M25 command problem?

    it could be a firmware thing ism not sure. but if some one could test theses files that would be good.

    test theses, this is the original file but with an added M25 on line 200.

    http://open-source-energy.org/rwg42985/russ/photos%20for%20other%20sites/Russ%20M25%20HollowDodecahedron%20prob.zip

    Thanks!!

    ~Russ


  • administrators

    Russ, thanks for those details, I was able to reproduce your download problem and will provide a fix as part of a new DWC version soon.

    Regarding your pause problem: It's a terrible idea to use M25 in G-code files, we have M226 for that and I fixed a related problem in the build from my last post. M25 should be only used from other G-code sources (like HTTP, USB or so). Please can you test my latest firmware build and let me know if that build resolves your issue?



  • On the subject of downloads would it be possible to change the meta type to something that actually downloads instead of always opening in the browser ? I go to backup the config and always have to hit download, then copy paste from the browser window and back into my backup file, etc. I know you can do a save as After the browser displays the file, but what a pain. This happens on FF and Chrome on all the PC's I've tested with, 3 or 4.

    Thanks,

    Jeff


Log in to reply