Restarts vs on/off while modifying firmware



  • I'm working on a kinematics mode for a custom printer (based off of 2.02RC1) and every time I get close to something I run into this problem. I spend a few hours tweaking and uploading new .bin files. Things work just fine. Then I power down for the day. When I come back the next morning, the kinematics mode no longer works. The motion in Z works fine, but the delta X and Y movements are no longer repeatable and are jumpy and off axis.

    I think I've narrowed down the "problem" to a full power on/off cycle. I'm sure the real problem is somewhere in my kinematics mode, but I'm surprised that it doesn't show up until I fully power cycle the printer. Any idea why this would be?

    I think I've mentioned it a few times before on these forums, but to give a little more detail, I'm essentially modifying a delta printer to have an extra set of axes to move the build plate(s) in and out of the print area. This necessitates modifying the MotorStepsToCartesian and CartesianToMotorSteps functions to account for the extra inputs. (I've disabled most of the auto calibration functions to make this process simpler.)

    Is it something to do with the length of motorPos[], machinePos[], or some other array assuming there are only 3 axes but I'm adding 2 more? Essentially I'm doing a few coordinate transforms, but for testing purposes I have made the transforms equal to 1, so it's strange to me that things would work after a reset but not after a power cycle.

    Possibly I'm just in over my head by attempting to modify a delta. There seem to be a lot of special cases required to get a delta running, which probably makes this harder.



  • Well, so far I'm an idiot. I never changed the constructor for my new class. That seems to have fixed it, so far.


  • administrators

    Probably caused by an uninitialised variable.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.