PanelDue Refuses to Update



  • So I've had a lot of problems trying to get a PanelDue board to actually work. The first one I ordered shipped with firmware for a 7" screen, which worked fine with that. Then when I followed all the correct steps and used Bossa to upload firmware for a 4.3" screen, everything went dark and never turned on again after I pressed the reset button for the first time. I worked for several hours trying to re-flash the board with different firmware and switching between the two screens. Nothing. I returned that board and ordered a new one, assuming there was just a problem with the board. Got the replacement board in this morning, exactly the same problem.

    To make sure I'm getting all this correct, I've been plugging in the PanelDue (with the screen attached) to my computer with the normal USB cable. The first time I did this the screen turned on. I then pressed erase for two seconds, then reset. After this the screen went dark. I refreshed the Bossa program to locate the board, and uploaded the correct firmware. I then press verify, which fails. After pressing reset on the board, Bossa no longer can find it even after multiple refreshes. I've also tried the read command after the write command, and then pressing verify. The program then says that the verification was successful, but still nothing on the actual board. Unplug the USB, plug it back into the Duet board and power everything on, and nothing. What am I doing wrong? The documentation for this board is severely lacking.


  • administrators

    Are you following the instructions at https://miscsolutions.wordpress.com/paneldue/, specifically the section on updating he firmware? Which operating system does your PC run?

    Check that you have downloaded the firmware file correctly, as described in the instructions. The file size should be about 120kb for the 5 and 7 inch screens and 83kb for the 4.3 inch screen. If the file you downloaded is a lot smaller then you haven't downloaded the file correctly.



  • I'm using a mac, the only windows computer in the house is 64 bit, which I can't get Bossa installed on. I've followed the mac instructions to the letter, but I think the problem with Bossa is that I can't put the install files into the bin folder because it's locked in El Capitian, so it's just been installed in applications as normal.


  • administrators

    You can run the 32-bit bossac.exe binary from the Tools folder of my GitHub RepRapFirmware repository on a 64-bit Windows computer.

    Did you check the downloaded file size?



  • Ok, we'll give that a shot. I'm talking to some of my more experienced software friends right now that are trying to help. Yes, I did check the file size, here's the folder;



  • Have you tried using samBA? I found this to work fine as long as you select SAM3S2 as processor.



  • My friend got this sorted out. After trying for about an hour on my Mac, he said it's impossible to do thanks to not having access to the required Bin folder and not being able to unlock it using terminal. He used Samba on his PC and got it working.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.