Print progress bug with tool duplication mode



  • I am on the latest 2.02RC5 code tree.
    I setup my independent quad extruder to do duplication mode -- 3 tools. Works fine, but the progress seems to be triple counting filament used and I suppose correctly decided that my 3 extruders have used more than a single print's worth of filament and have marked DWC as done. The PanelDue display now shows n/a for filament estimate time, and showing progress for layer time and file time, but DWC has decided that it's done -- though it's still printing.


  • administrators

    I can see why that would happen. I'll change firmware 2.02RC6 to use the total requested extrusion amount when a mixing extruder is in use, instead of the actual amount after allowing for mixing.



  • FYI -- I tweaked the tail end section of the gcode file where S3D puts in filament usage etc stuff, and in the current print I'm only doing dual duplication printing -- so I multiplied all numbers by 2. That works, but I noticed one tool was underextruding a tad, different filament brands, so seems it's a bit undersized, so I upped the extrusion multiplier to 104 -- that worked fine. But now the total used filament is going to be different since 1 tool is extruding at 100% and the other at 104%, so it will end up extruding in total more than S3D predicted anyway -- even * 2 -- not sure if you're change will account for that.


  • administrators

    @kazolar, the print progress indication already accounts for using different extrusion multipliers. What it currently doesn't allow for is the total filament mix not being equal to 1.0.



  • @dc42 got it -- PS -- love how super simple it was to add T4 and T5 for different combination of duplicate printing -- really slick, I thought I would need to have different config modes for regular iQUEX vs duplication, but this is super neat, I just have T4 defined as duplication of extruders on gantry 1 and T5 as duplication of extruders on gantry 1 and one of the tools on gantry 2 -- (the other tool has a different nozzle diameter, so can't include it in duplication mode)
    but I love how simple it was to setup and it worked the first time I tried it - both X an Y axis mapping in duplication -- really great.


Log in to reply