Dual Z endstop, and Dual Z motor



  • Does the firmware support simultaneous use of the Dual Z endstop, Dual Z motor and Dual Y endstop, Dual Y motor.
    Fee arduino DUE.
    How to implement it.
    It is also planned to do auto-calibration on an inductive sensor.
    Will this all work in parallel.


  • administrators

    On the Duet with DueX5 or other expansion to support the 6 motor drivers required, yes. On the Arduino Due + RADDS or other shield, it depends on whether it supports enough motors (6), endstop inputs (5 + Z probe) and axes (5). I don't look after the Due/RADDS port, but looking at the RADDS/Pins.h file, it appears to support 9 drivers, 4 endstops and 6 axes. So not enough endstop inputs. I guess you could modify the Pins.h file to use some additional pins as endstop inputs (if there are any free pins) and rebuild the firmware.



  • Hello

    I want to configure two engines on the Y axis and one endstop.

    In config.g

    M569 P1 S1 T5: 10: 10: 0; Drive y1 forwards
    M569 P2 S1 T5: 10: 10: 0; Drive y2 forwards

    M584 X0 Y1: 2 Z3 E5

    But with this configuration, only one engine rotates, the second stands still.

    what am i doing wrong?


  • administrators

    @vladimirrus007 said in Dual Z endstop, and Dual Z motor:

    Hello

    I want to configure two engines on the Y axis and one endstop.

    In config.g

    M569 P1 S1 T5: 10: 10: 0; Drive y1 forwards
    M569 P2 S1 T5: 10: 10: 0; Drive y2 forwards

    M584 X0 Y1: 2 Z3 E5

    But with this configuration, only one engine rotates, the second stands still.

    what am i doing wrong?

    Check that you have your M906 command to set motor currents after the M584 command, not before it. Likewise if you have a M350 command, it must be later in config.g than the M584 command.



  • @dc42 said in Dual Z endstop, and Dual Z motor:

    Check that you have your M906 command to set motor currents after the M584 command, not before it. Likewise if you have a M350 command, it must be later in config.g than the M584 command.

    It did not help.
    My configuration options

    M569 P0 S1 T5:10:10:0 ;Drive 0 goes forwards
    M569 P1 S1 T5:10:10:0 ;Drive 1 goes forwards
    M569 P2 S1 T5:10:10:0 ;Drive 2 goes forwards
    M569 P3 S1 T5:10:10:0 ;Drive 3 goes forwards
    M569 P4 S1 T5:10:10:0 ;Drive 4 goes forwards
    M569 P5 S1 T5:10:10:0 ;Drive 5 goes forwards
    M584 X0 Y1:2 Z3 E5 ;
    M350 X16 Y16:16 Z16 I0 ; Configure microstepping without interpolation
    M350 E16 I1 ; Configure microstepping with interpolation
    M92 X88.88 Y53.33:53.33 Z1280.00 E92.60 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y12000.00 Z300.00 E1200.00; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z100.00 E250.00; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00:800.00 Z800.00 E800.00 I30 ;Set motor currents (mA) and motor idle factor in per cent
    M84 S30



  • @vladimirrus007 I'm not 100% sure that this is your problem but it might be. Having mapped drives to axes using M584, you don't then need to reference the individual drives in subsequent commands that apply to those axes.

    So,
    M350 X16 Y16:16 Z16 I0 should be M350 X16 Y16 Z16 I0
    M92 X88.88 Y53.33:53.33 Z1280.00 E92.60 should be M92 X88.88 Y53.33 Z1280.00 E92.60
    M906 X800.00 Y800.00:800.00 Z800.00 E800.00 I30 should be M906 X800.00 Y800.00 Z800.00 E800.00 I30
    Your M566, M203 and M201 command are in the correct format.

    Edit. If you used multiple extruders, then each extruder should be separated by a colon, but not axes which share common drives.



  • I found a mistake. It was in the wrong pin step for the second driver Y.
    I fixed it and it all worked.
    Config as was and remained.

    thank


Log in to reply