Wrong coordinates after delta homing



  • Hello all,

    after slowly getting my duet maestro set up, I'm now at the point where I can home the delta, but after homing the coordinates read x0 y92.
    It then tries to reach x0 y0 by running the tool head off to the side, as if treating the y axis like on a cartesian printer.

    What setting am I missing that isn't positioning the center of the tool correctly?


  • administrators

    It sounds to me that you have a very large offset in one of the endstop corrections in your M666 command in config.g or config-override.g. Please post the contents of those files.



  • I tried both M666 X0 Y0 Z0 and M666 X0 Y0 Z0 A0 B0

    After restarting the board, it now sets y to 38.79 on homing instead.


  • administrators

    I'm guessing that you have some large tower angle offsets in M665 then (the XYZ parameters). I suggest you set those to zero (along with the M666 values) and re-run auto calibration.



  • M665 R91 L228 B88 H174 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    These are my two delta settings, as received from the reprap configurator. I haven't gotten to any offset calibration yet, as it can't even do basic homing at the moment. There is definitely an error in the geometry somewhere, as y moves are not horizontal, but I have no idea where to look for it.



  • Found it, M574 was missing the z endstop definition.

    I just double checked, this seems to be a bug in the RFF tool. Using it to generate a config file for a custom delta creates one where only X and y endstops are defined in M574.


  • administrators

    @naqaj said in Wrong coordinates after delta homing:

    Found it, M574 was missing the z endstop definition.

    I just double checked, this seems to be a bug in the RFF tool. Using it to generate a config file for a custom delta creates one where only X and y endstops are defined in M574.

    I'm glad you found the problem.

    When using the configurator, you need to select the correct endstop types in the Endstops page. The Z endstop defaults to Z-probe, which on a delta isn't helpful. I've verified that if I change it to "Active high switch", the correct M574 command is generated.



  • I've just gone through the tool again, using "no z-probe" in the Z-Probe settings and all three endstops set to active-high in the End-Stop settings, with none set to Z-Probe, like I did before. I left everything else on default presets

    I still get a file without the Z-endstop definition in M574. If you get a different result there must be another setting somewhere causing this.

    Either way, I think I can mark this as "solved"? Or can only admins do that?


  • administrators

    @naqaj said in Wrong coordinates after delta homing:

    I've just gone through the tool again, using "no z-probe" in the Z-Probe settings and all three endstops set to active-high in the End-Stop settings, with none set to Z-Probe, like I did before. I left everything else on default presets
    I still get a file without the Z-endstop definition in M574. If you get a different result there must be another setting somewhere causing this.

    I didn't set the Z probe type to None. I've just tested that, and I confirm that the Z parameter is missing in M574. We'll get that fixed. Thanks for reporting it!


  • administrators

    @naqaj Thank you for the report, I could reproduce and fix the problem.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.