WiFi Problems after Firmware Update



  • Hello

    I tried to update my Duet Wifi (Gen1). After the Update, the DWC was no more available. The Blue LED next to the WiFi Module flashes 2-3 Time (at about 1 Hz), then the LED is on for about 20 seconds permanently, then the LED starts to flash again. Somtimes this repeats for 2 or 3 loops, then the LED stays off.

    What i did:
    I tried different firmware versions (2.21, 1.20, 1.19) since i could not get an answer if there are firmware versions only vor Gen2 Duets or if i can pick every firmware vor every Duet. I also pushed the erase button and started from zero. I got different problems with every firmware, but the WiFi beaviour was always the same. Currently I am on firmware version 1.21, running on "Duet Wifi 1.02 or later".
    I disabled any other wifi source near the printer (Mobile Phone and Laptop) and unplugged the wifi router. Makes no difference

    My Printer is a custom made cartesian printer.

    So my main question are:

    1. Whats the best suitable firmware version for older duets?
    2. What can be the reason for the wifi behaviour?

    thanks for any help



  • Duet Wifi Gen1 ? From documentation i read that first generation Duets are Duet 0.6 and Duet 0.8.5 . Duet Wifi and Duet Ethernet are second generation boards. So witch one you have? Wifi or something else?.



  • I have a Duet WIFI. But i was confused about the name "Duet 2 Wifi". I searched my duet Wifi for any information about its version, but all i read was Duet Wifi, so i assumed there is already an updatet version of it. So if this isnt true, and i already heav a Duet 2 Wifi, the question about the firmware compatibility is obsolete 😃


  • administrators

    Hi, and welcome to the forum.

    All versions of the Duet WiFi and Duet Ethernet run the same firmware. The "Duet 2" name was a branding exercise prompted in part by one of our OEMs, to distinguish the newer Duets from the generation 1 Duets (versions 0.6 and 0.8.5) that had a lot less capability.

    When upgrading firmware, it's important to read the firmware upgrade notes for the new version and all versions that you may have skipped. If you've skipped a !of of firmware versions, this may take a little while.

    If the firmware you were coming from was earlier than 1.19 then see https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_If_your_Duet_2_WiFi_is_running_firmware_1_18_or_earlier. If the main and WiFi firmware versions are now out of step, see https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_How_to_recover_if_the_main_firmware_and_WiFi_firmware_versions_get_out_of_step_on_your_Duet_2_WiFi.

    HTH David



  • Thanks for the reply

    I followed the steps for updating from FW 1.18 or earlier. At least i thought i did. I always updatet via the SD card.
    First i downloaded version 2.02 from GitHub, put the .bin files on the SD card and installed via M997 S0:1
    I had some problems with this firmware, so i thought maybe the version 2 is for newer duets only, so i tried version 1.20.
    Still didn't work, so i pushed the erase button.
    Then i followed the tutorial "Recover from erase and basic setup" and installed FW 1.19

    Since the erase butten really erases everything, what firmware do i come from now? Does the Duet still know that it once ran FW 1.18?
    What FW should i try next?
    Is ist better not to skip any FW and install one after another?


  • administrators

    It's not necessary to go through all the firmware versions, but you need to be aware of the major changes that affected the firmware update process at particular versions:

    • At version 1.19 the split between the main and WiFi firmware was changed, and with it the method for setting up the WiFi SSID and password
    • At version 1.21 the firmware name was changed from DuetWiFiFirmware.bin to Duet2CombinedFirmware.bin. So if you are running 1.20 or earlier and you want to update to 1.21 or later via the SD card, you need to copy the new Duet2CombinedFirmware.bin file to DuetWiFiFirmware.bin, so that the 1.20 firmware recognises it.

    Please install firmware 2.02, then post any issues you have here and we'll try to help you. All Duet WiFi boards (even the white pre-production boards) can run this firmware.



  • Coming from Firmware 1.21 with not working WiFi i did the following steps:

    1. Erase all the old .bin files from the /sys folder
    2. Copy new .bin files to the /sys folder
    3. Extract the DuetWebControl.zip folder
    4. Erase the old /www folder and create a new one
    5. Put the files from the DuetWebControl folder in the /www folder
    6. Put a semicolon in front of the M552 S1
    7. Write a Macro via Notepad++ (edited an existing and saved with new name):
      M552 S0
      G4 S1000
      M587 S"My SSID" P"my Password"
    8. Put the SD Card back into the duet and power it up
    9. M997 S0 update was successful
    10. M997 S1 update was successful
    11. M587 and got:
      Remembered networks: MyNetwork IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0 MyNetwork IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0
    12. M552 S1 and got: WiFi module is connected to access point MyNetwork, IP Adress 192.168.2.113
      35 seconds later: WiFi reported error: Lost connection, auto reconnecting
      40 seconds later: WiFi reported error: Timed out while trying to connect to MyNetwork Wifi reported error: no known networks found WiFi modul is idle
      all these messages came twice in a loop, then it stopped to reconnect.

  • administrators

    Thanks. Please send M115 from USB to confirm that you are running main firmware 2.02. Then try to connect by sending M552 S1 (if necessary, send M552 S-1 to reset the WiFi module first). As soon as it has connected, send M122 (from USB again) to get the diagnostic report. I am interested in the WiFi section of the report.



  • Connecting...
    Printer is now online.

    M115
    SENDING:M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.02(RTOS) ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2018-12-24b1

    M552S1
    SENDING:M552S1
    WiFi module started
    WiFi module is connected to access point WLAN-XPJ6QA, IP address 192.168.2.113

    M122
    SENDING:M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DDM-9FAM2-LW4S8-6JTDD-3SS6J-9MWZZ
    Used output buffers: 1 of 20 (10 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98580 of which 0 recycled
    Exception stack ram used: 272
    Never used ram: 6696
    Tasks: NETWORK(ready,1428) HEAT(blocked,1232) MAIN(running,3736) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:05:43 ago, cause: power up
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 7840 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0xffffffff
    Error status: 0
    [ERROR] Error status: 0

    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 19.1, current 20.6, max 20.8
    Supply voltage: min 0.8, current 0.9, max 0.9, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 610139394
    Slowest loop: 99.73ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 22.82ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.22
      WiFi MAC address 5c:cf:7f:ee:5f:76
      WiFi Vcc 3.40, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 29984
      WiFi IP address 192.168.2.113
      WiFi signal strength -91dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0
      WiFi reported error: Lost connection, auto reconnecting

  • administrators

    @bundesoberweber said in WiFi Problems after Firmware Update:

    WiFi signal strength -91dBm, reconnections 0, sleep mode modem

    That's the problem. The WiFi signal strength is outside the usable range.


Log in to reply