Duet Wifi 1.01 not detected after firmware upgrade



  • I tried installing the latest 2.02 firmware, but now I cannot connect to my Duet wifi. (1.01)
    I've tried hitting the reset, hitting the erase, but each time it just comes up as "the last device malfunctioned"
    "Unknown USB Device (Device Descriptor Request failed)"

    USB\VID_0000&PID_0002\6&7BDA045&0&2

    It worked before I put in the firmware.

    I've tried an erase, but it still doesn't come up with a Com port.



  • Odd, after leaving it shut down and unplugged for half the day, it has now started being detected as a com port again.



  • Ok.
    Now I'm at

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.0 or 1.01
    Firmware Version: 2.01(RTOS) (2018-07-26b2)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6

    Is this the latest I should be running?



  • 2.02 is the latest. You can update by uploading this zip file in the settings> general page of the DWC. No need to unzip or anything.

    https://github.com/dc42/RepRapFirmware/releases/download/2.02/Duet2Firmware-2.02.zip


  • administrators

    @stoop said in Duet Wifi 1.01 not detected after firmware upgrade:

    I tried installing the latest 2.02 firmware, but now I cannot connect to my Duet wifi. (1.01)
    I've tried hitting the reset, hitting the erase, but each time it just comes up as "the last device malfunctioned"
    "Unknown USB Device (Device Descriptor Request failed)"

    USB\VID_0000&PID_0002\6&7BDA045&0&2

    It worked before I put in the firmware.

    I've tried an erase, but it still doesn't come up with a Com port.

    That's a common problem with Windows and certain USB hubs. The problem seems to be that when you reset a Duet that is connected to USB, the USB port disappears and reappears too fast for the hub to cope. I used to get it a lot (because I reset Duets so often), then I changed to a different USB hub and the problem went away.

    When I was using the old hub, every time the problem happened I moved the Duet to another USB port. When I ran out of ports, I disconnected the hub from the PC and reconnected it, and that got all the ports working again.

    I guess I could deliberately slow down the startup of the Duet to avoid this, but that would probably cause even more annoyance. I hate the way that so much electronics takes so long to start up. I'm sure my old 1950s TV started up faster than my current LCD TV, despite the valves (vacuum tubes) needing time for their heaters to reach operating temperature.



  • Its odd, no usb hub. (Well, I guess there is the internal one)
    But it was actually taking a long time to boot. Like 30 seconds.

    I tried all the USB ports on the laptop. No difference for any of them.

    Anyway, its all working now. (sorta)


  • administrators

    @stoop said in Duet Wifi 1.01 not detected after firmware upgrade:

    But it was actually taking a long time to boot. Like 30 seconds.

    That may indicate a problem with the SD card.


Log in to reply